PAT1043输出PATest

1043. 输出PATest(20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“PATestPATest....”这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按PATest的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:
redlesPayBestPATTopTeePHPereatitAPPT
输出样例:
PATestPATestPTetPTePePee
#include<stdio.h>
int main()
{
    int numP = 0,numA = 0,numT = 0,numE = 0,numS = 0,numt = 0;
    char str[10010];
    scanf("%s",&str);
    int i;
    for(i = 0;str[i] != '\0';i++)
    {
        if(str[i] == 'P') numP++;
        else if(str[i] == 'A') numA++;
        else if(str[i] == 'T') numT++;
        else if(str[i] == 'e') numE++;
        else if(str[i] == 's') numS++;
        else if(str[i] == 't') numt++;
    }
    while(numP || numA || numE || numS || numt || numT)
    {
        if(numP)
        {
            printf("P");
            numP--;
        }
        if(numA)
        {
            printf("A");
            numA--;
        }
        if(numT)
        {
            printf("T");
            numT--;
        }
        if(numE)
        {
            printf("e");
            numE--;
        }
        if(numS)
        {
            printf("s");
            numS--;
        }
        if(numt)
        {
            printf("t");
            numt--;
        }
    }
    printf("\n");
    return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值