Huffman Codes(使用priority_queue)

05-树9 Huffman Codes   (30分)

In 1953, David A. Huffman published his paper "A Method for the Construction of Minimum-Redundancy Codes", and hence printed his name in the history of computer science. As a professor who gives the final exam problem on Huffman codes, I am encountering a big problem: the Huffman codes are NOT unique. For example, given a string "aaaxuaxz", we can observe that the frequencies of the characters 'a', 'x', 'u' and 'z' are 4, 2, 1 and 1, respectively. We may either encode the symbols as {'a'=0, 'x'=10, 'u'=110, 'z'=111}, or in another way as {'a'=1, 'x'=01, 'u'=001, 'z'=000}, both compress the string into 14 bits. Another set of code can be given as {'a'=0, 'x'=11, 'u'=100, 'z'=101}, but {'a'=0, 'x'=01, 'u'=011, 'z'=001} is NOT correct since "aaaxuaxz" and "aazuaxax" can both be decoded from the code 00001011001001. The students are submitting all kinds of codes, and I need a computer program to help me determine which ones are correct and which ones are not.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2N63), then followed by a line that contains all the Ndistinct characters and their frequencies in the following format:

c[1] f[1] c[2] f[2] ... c[N] f[N]

where c[i] is a character chosen from {'0' - '9', 'a' - 'z', 'A' - 'Z', '_'}, andf[i] is the frequency of c[i] and is an integer no more than 1000. The next line gives a positive integer M (1000), then followed by Mstudent submissions. Each student submission consists of N lines, each in the format:

c[i] code[i]

where c[i] is the i-th character and code[i] is an non-empty string of no more than 63 '0's and '1's.

Output Specification:

For each test case, print in each line either "Yes" if the student's submission is correct, or "No" if not.

Note: The optimal solution is not necessarily generated by Huffman algorithm. Any prefix code with code length being optimal is considered correct.

Sample Input:

7
A 1 B 1 C 1 D 3 E 3 F 6 G 6
4
A 00000
B 00001
C 0001
D 001
E 01
F 10
G 11
A 01010
B 01011
C 0100
D 011
E 10
F 11
G 00
A 000
B 001
C 010
D 011
E 100
F 101
G 110
A 00000
B 00001
C 0001
D 001
E 00
F 10
G 11

Sample Output:

Yes
Yes
NoNo

#include<iostream>
#include<vector>
#include<queue>
#include<map>
#include<string>
using namespace std;

int TreeHeight;
int cnt=0;
int total=0;

map<char,int>m;

typedef struct TreeNode * Tree;
struct TreeNode{
	int data;
	char C;
	int height;
	Tree Left,Right;
};

struct cmp{
	bool operator()(Tree T1,Tree T2){
		return T1->data>T2->data;
	}
};

void Init(priority_queue<Tree,vector<Tree>,cmp>&p,int size){
	for(int i=0;i<size;i++){
		Tree T=new TreeNode;
		T->height=1;
		T->Left=T->Right=NULL;
		cin>>T->C>>T->data;
		m[T->C]=T->data;
		p.push(T);
	}
	while(p.size()>1){
		Tree T1=p.top();
		p.pop();
		Tree T2=p.top();
		p.pop();
		Tree T3=new TreeNode;
		T3->data=T1->data+T2->data;
		T3->C=' ';//新树的字符域为空格
		T3->Left=T1;
		T3->Right=T2;
		p.push(T3);
	}
	return ;
}

void PreOrder(Tree T){
	if(!T) return;
	else{
		if(T->Left==NULL&&T->Right==NULL){
		cnt=cnt+T->height*T->data;
		total++;
		}else{
			T->Left->height=T->height+1;
			T->Right->height=T->height+1;
			PreOrder(T->Left);
			PreOrder(T->Right);
		}
		return;
	}
}

void Compare(int size){
	int cmpcnt=0;
	char A;
	string B;
	vector<string>v;
	bool flag=false;
	for(int i=0;i<size;i++){
		cin>>A>>B;
		int lenv=v.size();
		for(int i=0;i<lenv;i++){
			if(v[i].find(B)==0) {flag=true;break;}
		}
		v.push_back(B);
		cmpcnt=cmpcnt+m[A]*B.length();
	}
	if(cmpcnt==cnt){
		if(flag==false)
		cout<<"Yes"<<endl;
		else
		cout<<"No"<<endl;
		return ;
	}else{
		cout<<"No"<<endl;
		return ;
	}
		
}

int main(){
	priority_queue<Tree,vector<Tree>,cmp>p;
	int size;
	cin>>size;
	Init(p,size);
	Tree HuffmanTree=p.top();
	p.pop();
	HuffmanTree->height=0;
	PreOrder(HuffmanTree);
	int t;
	cin>>t;
	while(t--){
		Compare(size);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,以下是用 C 语言写的 Huffman 编码程序示例: ```c #include <stdio.h> #include <stdlib.h> #include <string.h> struct node { int val; int freq; struct node* left; struct node* right; }; struct priority_queue { int size; int capacity; struct node** values; }; struct node* new_node(int val, int freq) { struct node* n = (struct node*) malloc(sizeof(struct node)); n->val = val; n->freq = freq; n->left = NULL; n->right = NULL; return n; } struct priority_queue* create_pq(int capacity) { struct priority_queue* pq = (struct priority_queue*) malloc(sizeof(struct priority_queue)); pq->size = 0; pq->capacity = capacity; pq->values = (struct node**) malloc(capacity * sizeof(struct node*)); return pq; } void swap_nodes(struct node** a, struct node** b) { struct node* temp = *a; *a = *b; *b = temp; } void min_heapify(struct priority_queue* pq, int i) { int smallest = i; int left = 2 * i + 1; int right = 2 * i + 2; if (left < pq->size && pq->values[left]->freq < pq->values[smallest]->freq) smallest = left; if (right < pq->size && pq->values[right]->freq < pq->values[smallest]->freq) smallest = right; if (smallest != i) { swap_nodes(&pq->values[i], &pq->values[smallest]); min_heapify(pq, smallest); } } void push_pq(struct priority_queue* pq, struct node* value) { if (pq->size == pq->capacity) { printf("Priority queue overflow.\n"); return; } int i = pq->size; pq->size++; pq->values[i] = value; while (i > 0 && pq->values[(i - 1) / 2]->freq > pq->values[i]->freq) { swap_nodes(&pq->values[i], &pq->values[(i - 1) / 2]); i = (i - 1) / 2; } } struct node* pop_pq(struct priority_queue* pq) { if (pq->size == 0) { printf("Priority queue underflow.\n"); return NULL; } struct node* value = pq->values[0]; pq->size--; pq->values[0] = pq->values[pq->size]; min_heapify(pq, 0); return value; } int is_leaf(struct node* node) { return node->left == NULL && node->right == NULL; } void print_arr(int arr[], int n) { for (int i = 0; i < n; i++) printf("%d", arr[i]); printf("\n"); } void print_codes(struct node* root, int arr[], int top) { if (root->left) { arr[top] = 0; print_codes(root->left, arr, top + 1); } if (root->right) { arr[top] = 1; print_codes(root->right, arr, top + 1); } if (is_leaf(root)) { printf("%d: ", root->val); print_arr(arr, top); } } void huffman_codes(int data[], int freq[], int size) { struct priority_queue* pq = create_pq(size); for (int i = 0; i < size; i++) push_pq(pq, new_node(data[i], freq[i])); while (pq->size > 1) { struct node* left = pop_pq(pq); struct node* right = pop_pq(pq); struct node* parent = new_node(-1, left->freq + right->freq); parent->left = left; parent->right = right; push_pq(pq, parent); } int arr[100]; int top = 0; struct node* root = pop_pq(pq); print_codes(root, arr, top); } int main() { int data[] = { 'a', 'b', 'c', 'd', 'e', 'f' }; int freq[] = { 5, 9, 12, 13, 16, 45 }; int size = sizeof(data) / sizeof(data[0]); huffman_codes(data, freq, size); return 0; } ``` 在这个示例中,我们通过使用优先队列(最小)和哈夫曼树的经典算法来生成哈夫曼编码。 首先,我们将每个字符视为节点,并使用其出现频率作为该节点的频率。 将这些节点插入优先队列中,通过找到两个具有最小频率的节点(通过弹出优先队列顶部)。我们将它们的和作为新节点的频率,并将该新节点插入优先队列中。如此反复,直到我们获得一个包含所有节点的树。 遍历这个树,将左侧的子树标记为「0」,右侧子树标记为「1」,并将该操作递归地应用于整个树。当遇到叶节点时,它的路径就是该节点的哈夫曼编码。最后,打印字符和它们的哈夫曼编码。 这是一个朴素的哈夫曼编码实现,但足以说明其基本工作原理。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值