数据结构上机测试2-1:单链表操作A SDUT——1138

数据结构上机测试2-1:单链表操作A

Time Limit: 1000 ms Memory Limit: 4096 KiB

Submit Statistic Discuss

Problem Description

输入n个整数,先按照数据输入的顺序建立一个带头结点的单链表,再输入一个数据m,将单链表中的值为m的结点全部删除。分别输出建立的初始单链表和完成删除后的单链表。

Input

第一行输入数据个数n;
第二行依次输入n个整数;
第三行输入欲删除数据m。

Output

第一行输出原始单链表的长度;
第二行依次输出原始单链表的数据;
第三行输出完成删除后的单链表长度;
第四行依次输出完成删除后的单链表数据。

Sample Input

10
56 25 12 33 66 54 7 12 33 12
12

Sample Output

10
56 25 12 33 66 54 7 12 33 12
7
56 25 33 66 54 7 33

Hint

Source

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

struct node
{
    struct node *next;
    int data;
}*head, *tail, *p;
struct node *creat(int n)
{
    int i;
    struct node *head, *p, *tail;
    head=(struct node*)malloc(sizeof(struct node));
    head ->next= NULL;
    tail = head;
    for(i = 0; i < n; i++)
    {
        p = (struct node*)malloc(sizeof(struct node));
        scanf("%d", &p->data);
        p -> next = NULL;
        tail -> next = p;
        tail = p;
    }
    return head;
};
void show (struct node *head)
{
    struct node *t;
    t = head -> next;
    while(t)
    {
        if(t -> next != NULL)printf("%d ", t -> data);
        else printf("%d\n", t -> data);
        t = t -> next;
    }
}
int main()
{
    int n, m;
    scanf("%d", &n);head = creat(n);
    scanf("%d", &m);printf("%d\n", n);show(head);
    tail = head;p = head -> next;
    while(p != NULL)
    {
        if(p->data == m)
        {
            tail ->next = p -> next;free(p);p = tail ->next;n--;
        }
        else
            {tail = tail -> next;p = p -> next;}
    }
    printf("%d\n", n);show(head);
    return 0;
}


/***************************************************
Result: Accepted
Take time: 0ms
Take Memory: 144KB
Submit time: 2018-08-01 15:44:44
****************************************************/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值