翻译布尔表达式
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
大家都学过了布尔表达式的翻译,其中有一个拉链-回填技术,这次我们就练习这个技术。
Input
输入为一行字符串,例如: a < b or c < d and e < f
每个符号都用空格间隔。
其中逻辑运算符包含 and 和 or , 关系运算符包含 < 、> 、<= 、 >= 、== 、 != 。
Output
假链跳到0,真链跳到1,表达式序号从100开始排。
Sample Input
a < b or c < d and e < f
Sample Output
100(j<,a,b,1)
101(j,_,_,102)
102(j<,c,d,104)
103(j,_,_,0)
104(j<,e,f,100)
105(j,_,_,103)
#include <bits/stdc++.h>
using namespace std;
string str, a;
int id = 100, t = 1, f = 100;
vector<string> d;
int main()
{
getline(cin,str);
str += " ed";
stringstream ss(str);
while(ss>>a)
{
if(a=="or"||a=="ed")
{
if(a=="or")
f += 2;
else
f = 0;
int n = d.size();
int i = 0;
for(i=0; i<n-3; i+=3)
{
printf("%d(j%s,%s,%s,%d)\n",id, d[i+1].c_str(), d[i].c_str(), d[i+2].c_str(), id+2);
id++;
printf("%d(j,_,_,%d)\n",id, f);
f = id++;
}
printf("%d(j%s,%s,%s,%d)\n",id, d[i+1].c_str(), d[i].c_str(), d[i+2].c_str(), t);
t = id++;
printf("%d(j,_,_,%d)\n",id, f);
id++;
d.clear();
if(a=="ed")
break;
}
else if(a=="and")
f += 2;
else
d.push_back(a);
}
return 0;
}