数据结构实验之二叉树八:(中序后序)求二叉树的深度

数据结构实验之二叉树八:(中序后序)求二叉树的深度

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

已知一颗二叉树的中序遍历序列和后序遍历序列,求二叉树的深度。

Input

输入数据有多组,输入T,代表有T组数据。每组数据包括两个长度小于50的字符串,第一个字符串表示二叉树的中序遍历,第二个表示二叉树的后序遍历。

Output

输出二叉树的深度。

Sample Input

2
dbgeafc
dgebfca
lnixu
linux

Sample Output

4
3

Hint

Source

#include <bits/stdc++.h>

using namespace std;

struct bitree
{
    char data;
    struct bitree *lc;
    struct bitree *rc;
};
bitree *create(int n,char a[],char b[])
{
    bitree *tree;
    int i;
    if(!n)
        tree = NULL;
    else
    {
        tree = new bitree;
        tree->data = b[n-1];
        for(i=0; i<n; i++)
        {
            if(a[i]==b[n-1])
                break;
        }
        tree->lc = create(i,a,b);
        tree->rc = create(n-i-1,a+i+1,b+i);
    }
    return tree;
}
int depth(bitree *tree)
{
    int d = 0;
    if(tree)
    {
        int ld = depth(tree->lc);
        int rd = depth(tree->rc);
        d = ld>rd?ld+1:rd+1;
    }
    return d;
}
int main()
{
    int t;
    bitree *tree;
    char a[51],b[51];
    cin>>t;
    while(t--)
    {
        cin>>a>>b;
        int n = strlen(a);
        tree = create(n,a,b);
        cout<<depth(tree)<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值