pat甲级 1001 a+b

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 

 题目解释:输出a+b结果,每三位加一逗号,还有前面的负号。

方法一:%03d输出

#include<iostream>
using namespace std;
int main() {
	int a, b;
	while (cin >> a >> b) {
		int c = a + b;//考虑七位数、四位数、更少的情况
		if (c < 0) {
			cout << '-'; c = -c; 
		}
		if (c >= 1000000 )
			printf("%d,%03d,%03d\n", c / 1000000, (c  % 1000000) / 1000, c % 1000);
		else if (c >=1000 )
			printf("%d,%03d\n", c / 1000, c % 1000);
		else
			printf("%d\n", c);
	}
	return 0;
}

方法二:字符串输出

#include<iostream>
#include<string>
using namespace std;
int main() {
	int a, b,i;
	while (cin >> a >> b) {
		string c = to_string(a + b);
		int len = c.length();
		for (i = 0; i < len; i++) {
			cout << c[i];
			if (c[i] == '-') continue;
			else if ((i+1)%3==len%3 && i != len - 1)	cout << ",";
		}
		cout << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值