PAT甲级1001

1001.A+B Format(20)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

计算a+b,并把他们的和以标准形式输出,即每三个数字一组用都逗号隔开(除非结果少于4个数字)。

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

每一个输入文件包含一个测试。每个测试包含一对数字a,b;-1000000 <= a, b <= 1000000。a和b之间用一个空格间隔。

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

对每一个测试,你应该把结果以标准形式输出在一行。


Sample Input

-1000000 9

Sample Output

-999,991


代码:

#include<stdio.h>
#include<cstring>
#include<math.h>
#include<iostream>
#include <algorithm>
#include<cmath>
using namespace std;

int main()
{
	int a,b;
	int result[7];
	for(int i=0;i<7;i++)
		result[i]=0;
	cin>>a>>b;
	int sum=a+b;
	if(sum<0)
	{
		cout<<"-";
		sum*=-1;
	}
	if(sum==0)
	{
		cout<<"0";
		return 0;
	}
	int count=0;
	while(sum!=0)
	{
		result[count++]=sum%10;
		sum/=10;
	}
	for(int i=count-1;i>=0;i--)
	{
		cout<<result[i];
		count--;
		if(count%3==0&&count!=0)
			cout<<",";
	}
	system("pause");
	return 0;
}


分析:
一开始做这道题的思路是 把相加的结果对1000取余,并存到数组里,后来发现这种做法会造成一个很大的错误,那就是会出现这样的情况:
正确结果:1,000,123 不正确的输出:1,0,123.
所以换了一个思路,把结果对10取余,把结果的每一位分别存到数组里,再按规定格式输出。


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值