AlvinNoending的专栏

专注改变菜鸟,灵感成就大神

JSTL在eclipse中的配置

JSTL是一个非常用的东西,在myeclipse 中集成了jstl,所以只需要在jsp页面头部添加如下一句话就可以使用jstl的core标签库:

<%@ taglib prefix="c" uri="http://java.sun.com/jsp/jstl/core" %>

但是eclipse是没有任何插件的,所以要使用jstl需要自己配置,配制方法如下:


1、jstl1.0或以下的版本:

需要将jstl.jar和standard.jar包放入WEB-INF\lib下
在WEB-INF文件夹下放入所用到得.tld文件
在web.xml文件中配置taglib信息
<jsp-config>
  <taglib>
  <taglib-uri>http://java.sun.com/jstl/core</taglib-uri>
  <taglib-location>/WEB-INF/tlds/c.tld</taglib-location>
  </taglib>
  <taglib>
  <taglib-uri>http://java.sun.com/jstl/core-rt</taglib-uri>
  <taglib-location>/WEB-INF/tlds/c-rt.tld</taglib-location>
  </taglib>
</jsp-config>
在jsp页面中使用<%@ taglib prefix="c" uri="http://java.sun.com/jstl/core"%>
2、对于jstl-1.1以上的版本:
JSTL1.1以上的版本只用在lib中加入下载的jar包(jstl.jar),并在JSP页面头部加上这样一句话:
<%@ taglib uri="http://java.sun.com/jsp/jstl/core" prefix="c" %>,用来指明jar包的URL,
并且,在Web.xml文件中不用做任何配置。

注意:
<1>、如果servlet是2.4版本以上(包含2.4)的则可以直接使用,如果是其他版本的话,jsp的属性isELIgnored默认值为true,页面对el表达式不计算,所以要使用jstl的话,则需要使用isELIgnored="false"属性.如:<%@page isELIgnored="false"%>
<2>、如何查看jsp和servlet版本可以参见如下方式:tomcat的lib目录下有两个jar文件,分别名为jsp-api.jar和servlet-api.jar。解压这两个文件,用Notepad++之类的软件打开在其中的Meta-Info文件夹下的MANIFEST.MF文件,可以从Specification-Version看出其版本。


阅读更多
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

JSTL在eclipse中的配置

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭