UVA1595 Symmetry(暴力模拟)

题意:

The figure shown on the left is left-right symmetric as it is possible to fold the sheet of paper along a vertical line, drawn as a dashed line, and to cut the figure into two identical halves. The figure on the right is not left-right symmetric as it is impossible to find such a vertical line.

Write a program that determines whether a figure, drawn with dots, is left-right symmetric or not. The dots are all distinct.
 

Input:

The input consists of T test cases. The number of test cases T is given in the first line of the input file. The first line of each test case contains an integer N, where N (1 ≤ N ≤ 1,000) is the number of dots in a figure. Each of the following N lines contains the x-coordinate and y-coordinate of a dot. Both x-coordinates and y-coordinates are integers between −10,000 and 10,000, both inclusive.
 

Output:

Print exactly one line for each test case. The line should contain ‘YES’ if the figure is left-right symmetric, and ‘NO’, otherwise.
 

Sample Input:

3

5

-2 5

0 0

6 5

4 0

2 3

4

2 3

0 4

4 0

0 0

4

5 14

6 10

5 10

6 14

 

Sample Output:

YES

NO

YES
 

分析:
题意就是给你一些点,是否能组成一个左右对称的图形,所以读题一定要仔细啊,我最开始只看到对称图形,还迷茫了一下难道要判断左右对称、上下对称、斜对称,那不是要死人了,再仔细读了下题才确定是左右对称,弱读题的菜鸡真的伤不起。我最开始想的方法有点复杂,是找到最中间的轴,把点排序后分为两部分,然后左右散开扫一遍是不是对应的,但是这又得考虑到同一个x位置上可能有多个点,就涉及到y轴上的分布,成功把自己绕了进去,看了大佬的解题报告,真的妙啊,把点集升序和降序分别排一遍,顺序扫一遍看dot1[i].x+dot[2].x是否等于中轴的两倍,因为y轴是按照同一个顺序排列的,y轴只需要考察是否相等就可以了,秒啊。中轴的找法是最左边的点和最右边的点的横坐标相加除以二。

 

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 1010;
int t, n, l, r, temp;

struct node{
	int x,y;
};

node dot1[maxn], dot2[maxn];

bool cmp1(node a, node b){
	if(a.x == b.x)
		return a.y > b.y;
	return a.x < b.x;
}

bool cmp2(node a, node b){
	if(a.x == b.x)
		return a.y > b.y;
	return a.x > b.x;
}

bool ava(){
	for(int i = 0; i < n; i++){
		if(dot1[i].x + dot2[i].x != temp) return false;
		else if(dot1[i].y != dot2[i].y) return false;
	}
	return true;
}

int main(){
	cin>>t;
	while(t--){
		cin>>n;
		int a, b;
		l = 10010;
		r = -10010;
		for(int i = 0; i < n; i++){
			cin>>a>>b;
			dot1[i].x = dot2[i].x = a;
			dot1[i].y = dot2[i].y = b;
			if(a < l)  l = a;
			if(a > r)  r = a;
		}
		sort(dot1, dot1+n, cmp1);
		sort(dot2, dot2+n, cmp2);
		
		temp = l + r;
		
		if(ava()) cout<<"YES"<<endl;
		else cout<<"NO"<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值