数据结构实验之查找三:树的种类统计(先排序树再中序遍历)

Problem Description

随着卫星成像技术的应用,自然资源研究机构可以识别每一个棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。

Input

输入一组测试数据。数据的第1行给出一个正整数N (n <= 100000),N表示树的数量;随后N行,每行给出卫星观测到的一棵树的种类名称,树的名称是一个不超过20个字符的字符串,字符串由英文字母和空格组成,不区分大小写。

Output

按字典序输出各种树的种类名称和它占的百分比,中间以空格间隔,小数点后保留两位小数。

Example Input
2
This is an Appletree
this is an appletree
Example Output
this is an appletree 100.00%

Hint

//先用二叉排序树排个序,比根结点大的放在右边,比跟结点小的放在左边。排序二叉树建好了,然后用中序遍历输出,为什么选择中序遍历,是因为题目中要求是按照字典序输出,字典序就是从小到大 依次输出。中序遍历在排序二叉树中就是从小到大输出的。

==============================================

不能随随便便改变 s1 与 s2 在 strcmp中的位置; 

1.strcmp(s1,s2)>0  说明 :s1>s2 ; 

2.strcmp(s2,s1)<0 说明: s2<s1 ;   

1 和 2 所表示的大小关系是一样的,但是所表达的含义有一点不一样;  

==============================================

3.strcmp(s1,s2)<0   说明:s1<s2 

4.strcmp(s2,s1)>0 说明 :s2>s1 

3 ,4 与 1 ,2 一样的类型;

===============================================

strcmp(s1,s2)==0  说明:s1==s2


================================================

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
using namespace std ;

char s[22] ;

struct stu
{
    char data[22] ;
    int num  ;
    struct stu *lchild ;
    struct stu *rchild ;
};


void creat(struct stu *&t)
{
    if(t==NULL)
    {
        t = (struct stu *)malloc(sizeof(struct stu));
        t -> num = 1 ;
        t -> lchild = NULL ;
        t -> rchild = NULL ;
        strcpy(t->data,s) ;
    }
    else
    {
        if(strcmp(s,t->data)==0)  //strcmp(s1,s2)==0 s1 = s2  strcmp(s1,s2)>0  s1>s2   strcmp(s1,s2)<0 s1<s2
        {
            t -> num ++ ;
        }
        else if(strcmp(s,t->data)>0) //如果是if(strcmp(t->data,s)>0) 因为t->data>s 所以{creat(t->lchild);} 而不是{creat(t->rchild);}了。
        {
            creat(t->rchild);
        }
        else if(strcmp(s,t->data)<0) 
        {
            creat(t->lchild) ;
        }
    }
}

void zhongxubianli(struct stu *&t,int n)
{
    if(t!=NULL)
    {
        zhongxubianli(t->lchild,n) ;
        printf("%s %.2lf%%\n",t->data,(1.0*t->num/n)*100);
        zhongxubianli(t->rchild,n) ;
    }
}


int main()
{
    int n ;
    scanf("%d",&n);
    struct stu *t = NULL ;
    getchar();
    for(int j=0;j<n;j++)
    {
         gets(s);
         int l = strlen(s) ;
         int i ;
         for(i=0;i<l;i++)
         {
             if(s[i]>='A'&&s[i]<='Z')
             s[i] = s[i] + 32 ;
         }
         creat(t);
    }
    zhongxubianli(t,n) ;
    return 0 ;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值