数据结构实验之查找二:平衡二叉树

题目描述

根据给定的输入序列建立一棵平衡二叉树,求出建立的平衡二叉树的树根。

输入

输入一组数据。数据的第1行给出一个正整数N(n <= 20),N表示输入序列的元素个数;第2行给出N个正整数,按数据给定顺序建立平衡二叉树。

输出

输出平衡二叉树的树根。

示例输入

5
88 70 61 96 120

示例输出

70
 
 
 
 
具体做法和解释请看:  http://blog.csdn.net/flying_star521/article/details/52311038   这篇博客写的十分的详细。
 
 
#include <stdio.h>
#include <stdlib.h>
#include <string.h>


typedef int Elemtype;


typedef struct node
{
    Elemtype data;
    int d;
    struct node *lchild,*rchild;
};


int max(int x,int y)
{
    return x>y ? x:y;
}


int Deep(struct node *head)
{
    if (!head)
        return -1;
    else return head->d;
}


struct node *LL(struct node *head)//右旋
{
 struct node *p = head->lchild;
 head->lchild = p->rchild;
 p->rchild = head;
 p->d = max(Deep(p->lchild),Deep(p->rchild))+1;
 head->d = max(Deep(head->lchild),Deep(head->rchild))+1;
 return p;
}


struct node *RR(struct node *head)//左旋
{
 struct node *p = head->rchild;
 head->rchild = p->lchild;
 p->lchild = head;
 p->d = max(Deep(p->lchild),Deep(p->rchild))+1;
 head->d = max(Deep(head->lchild),Deep(head->rchild))+1;
 return p;
}


struct node *LR(struct node *head)
{
  head->lchild = RR(head->lchild);//先做左旋
  return LL(head);//在做右旋
}


struct node *RL(struct node *head)
{
 head->rchild = LL(head->rchild);//先做右旋
 return RR(head);//在做左旋
}
struct node *Creat(struct node *head,int x)
{
    if (head == NULL)
    {
        head = (struct node *)malloc (sizeof (struct node));
        head->data = x;
        head->d = 0;
        head->rchild = head->lchild = NULL;
    }
    else if (head->data > x)
    {
        head->lchild = Creat(head->lchild,x);
        if (Deep(head->lchild)-Deep(head->rchild)>1)
        {
            if (head->lchild->data > x)
                head = LL(head);
            else
                head = LR(head);
        }
    }
    else if (head->data < x)
    {
        head->rchild  = Creat(head->rchild,x);
        if (Deep(head->rchild)-Deep(head->lchild)>1)
        {
            if (head->rchild->data > x)
                head = RL(head);
            else
                head = RR(head);
        }
    }
    head->d = max(Deep(head->lchild),Deep(head->rchild))+1;
    return head;
}


int main()
{
    int n,m;
    scanf ("%d",&n);
    struct node *head = NULL;
    for (int i=0; i<n; i++)
    {
        scanf ("%d",&m);
        head = Creat(head,m);
    }
    printf ("%d\n",head->data);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值