ZOJ Problem Set - 3498||Javabeans

Javabeans

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Javabeans are delicious. Javaman likes to eat javabeans very much.

Javaman has n boxes of javabeans. There are exactly i javabeans in the i-th box (i = 1, 2, 3,...n). Everyday Javaman chooses an integer x. He also chooses several boxes where the numbers of javabeans are all at least x. Then he eats x javabeans in each box he has just chosen. Javaman wants to eat all the javabeans up as soon as possible. So how many days it costs for him to eat all the javabeans?

Input

There are multiple test cases. The first line of input is an integer T ≈ 100 indicating the number of test cases.

Each test case is a line of a positive integer 0 < n < 231.

Output

For each test case output the result in a single line.

Sample Input

4
1
2
3
4

Sample Output

1
2
2
3
 
题目一开始不太理解,后来发现是有规律的,输出是1,2,2,3。。不难猜出这个规律是输出1个1,2个2,4个3,8个4等等。所以代码就很简单了,一次AC~~
 
#include <iostream>
#include <math.h>
using namespace std;
int main()
{
	int t;
	cin >> t;
	while (t--)
	{
		int n,i=1;
		cin >> n;
		if (n == 1)
			cout << "1" << endl;
		else
		{
			while (pow(2.0, i) <= n)
			{
				i++;
			}
			cout << i << endl;
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值