ZOJ Problem Set - 3872||Beauty of Array

Beauty of Array

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input
3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2
Sample Output
105
21

38

求所有子数组之和,只计算不重复的数,重复的数则只算一次。

思路:2 3 3 2

3 3 2

3 2

2

关键代码:dp[i]=dp[i-1]+i*a-hsh[a]*a;//减去重复的所有a;

hsh[a]=i;//因为i*a,所以记录之前累加的a有i个。

我的LEN为100005,电脑调试运行黑框框一弹出来就又弹出了停止运行工作了。

不过代码可以AC!!!

然后我听了别人的把数组定义在了main外面。可以运行了,但是代码却不能AC了。之前我也觉得LEN为100005太小了。但是就是AC了。。讲究一下吧。

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
#define LEN 100005
#define LL long long
int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		int a,n,i;
		LL ans = 0;
		LL dp[LEN];
		int hsh[LEN] = { 0 };
		dp[0] = 0;
		scanf("%d", &n);
		for (i = 1; i <= n; i++)
		{
			scanf("%d", &a);
			dp[i] = dp[i - 1] + a*i-hsh[a]*a;
			hsh[a] = i;
		}
		for (i = 1; i <= n; i++)
			ans += dp[i];
		printf("%lld\n", ans);
	}
	return 0;
}




另外附上以外一个大神的代码,可以调试运行,AC成功。他是加上了不重复的a


#include <iostream>
#include <stdio.h>
#include <string.h>
#define LEN 1000005
#define LL long long
using namespace std;
LL dp[LEN];
int hsh[LEN];
int main()
{
	int t, n, a;
	scanf("%d", &t);
	while (t--)
	{
		memset(hsh, 0, sizeof(hsh));
		scanf("%d", &n);
		dp[0] = 0;
		for (int i = 1; i <= n; i++)
		{
			scanf("%d", &a);
			dp[i] = dp[i - 1] + a + (i - 1 - hsh[a])*a;
			hsh[a] = i;
		}
		LL ans = 0;
		for (int i = 1; i <= n; i++)
			ans += dp[i];
		printf("%lld\n", ans);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值