数据结构上机测试2-2:单链表操作B

题目描述

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

输入

第一行输入元素个数n;
第二行输入n个整数。

输出

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

示例输入

10
21 30 14 55 32 63 11 30 55 30

示例输出

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

 

 

 

#include <bits/stdc++.h>
using namespace std;

struct node
{
    int data;
    struct node *next;
};
int main()
{
    int i,n;
    struct node *head,*p,*q,*r;
    head = new struct node();
    head -> next = NULL;
    cin>>n;
    for(i=0; i<n; i++)
    {
        q=new struct node();
        cin>>q->data;
        q->next=head->next;
        head->next=q;
    }
    cout<<n<<endl;
    p=head->next;
    while(p!=NULL)
    {
        cout<<p->data;
        if(p->next!=NULL)
            cout<<" ";
        p=p->next;
    }
    cout<<endl;
    p=head->next;
    while(p!=NULL)
    {
        r=p;
        q=r->next;
        while(q!=NULL)
        {
            if(q->data==p->data)
            {
                r->next=q->next;
                free(q);
                q=r->next;
                n--;
            }
            else
            {
                r=r->next;
                q=q->next;
            }
        }
        p=p->next;
    }
    cout<<n<<endl;
    p=head->next;
    while(p!=NULL)
    {
        cout<<p->data<<" ";
        p=p->next;
    }
    cout<<endl;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值