题目链接:点击打开链接
3-7 类的友元函数的应用
Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
通过本题目的练习可以掌握类的友元函数的定义和用法
要求设计一个点类Point,它具有两个double型的数据成员x,y。为该类设计构造函数。并为其添加一个友元函数用于计算并输出两点间的距离;再添加一个输出成员函数用于输出点的信息。
并编写主函数,实现以下的输入输出内容。
Input
4个double型的数,中间用一个空格间隔。
Output
输出数据共3行,前两行用于显示要求距离的两个点的信息,第三行显示两点的距离。
Example Input
5 6 2 3
Example Output
The first point is the coordinate:X=5,Y=6
The second point is the coordinate:X=2,Y=3
The distance between the two points is:4.24264
Hint
Author
黄晶晶
代码实现:
#include <iostream>
#include <math.h>
#include <iomanip>
using namespace std;
class Point
{
private:
double x,y;
public:
Point(double a = 0,double b = 0);
void display()
{
cout<<"X="<<x<<","<<"Y="<<y<<endl;//
}
friend double dist(Point &A,Point &B);
};
Point::Point(double a,double b)
{
x = a;y = b;
}
double dist(Point &A,Point &B)
{
double a = (A.x - B.x)*(A.x - B.x) + (A.y - B.y)*(A.y - B.y);
return sqrt(a);
}
int main()
{
double a,b,c,d;
cin>>a>>b>>c>>d;
Point A(a,b);
cout<<"The first point is the coordinate:";
A.display();
Point B(c,d);
cout<<"The second point is the coordinate:";
B.display();
cout<<"The distance between the two points is:"<<dist(A,B)<<endl;
return 0;
}