Java sdut acm 1140 面向对象程序设计上机练习一(函数重载)

题目链接:点击打开链接

面向对象程序设计上机练习一(函数重载)
Time Limit: 1000MS Memory Limit: 65536KB
Submit Statistic
Problem Description


利用数组和函数重载求5个数最大值(分别考虑整数、单精度、长整数的情况)。
Input


分别输入5个int型整数、5个float 型实数、5个long型正整数。
Output


分别输出5个int型整数的最大值、5个float 型实数的最大值、5个long型正整数的最大值。
Example Input


11 22 666 44 55
11.11 22.22 33.33 888.88 55.55
1234567 222222 333333 444444 555555
Example Output


666
888.88
1234567
Hint


Author


zlh


代码实现:

import java.util.Scanner;

public class Main {
	static int max(int a,int b,int c,int d,int e){
		int max = a;
		if(max < b) max = b;
		if(max < c) max = c;
		if(max < d) max = d;
		if(max < e) max = e;
		return max;
	}
	static long max(long a,long b,long c,long d,long e){
		long max = a;
		if(max < b) max = b;
		if(max < c) max = c;
		if(max < d) max = d;
		if(max < e) max = e;
		return max;
	}
	static float max(float a,float b,float c,float d,float e){
		float max = a;
		if(max < b) max = b;
		if(max < c) max = c;
		if(max < d) max = d;
		if(max < e) max = e;
		return max;
	}
	public static void main(String[] args) {
		Scanner input = new Scanner(System.in);
		int a1 = input.nextInt();
		int b1 = input.nextInt();
		int c1 = input.nextInt();
		int d1 = input.nextInt();
		int e1 = input.nextInt();
		int ma1 = max(a1,b1,c1,d1,e1);
		
		float a2 = input.nextFloat();
		float b2 = input.nextFloat();
		float c2 = input.nextFloat();
		float d2 = input.nextFloat();
		float e2 = input.nextFloat();
		float ma2 = max(a2,b2,c2,d2,e2);
		
		long a3 = input.nextLong();
		long b3 = input.nextLong();
		long c3 = input.nextLong();
		long d3 = input.nextLong();
		long e3 = input.nextLong();
		long ma3 = max(a3,b3,c3,d3,e3);
		
		System.out.println(ma1+"\n"+ma2+"\n"+ma3);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值