Java之 面向对象程序设计上机练习一(函数重载)

面向对象程序设计上机练习一(函数重载) 
Time Limit: 1000 ms Memory Limit: 65536 KiB 
Problem Description 
利用数组和函数重载求5个数最大值(分别考虑整数、单精度、长整数的情况)。 
Input 
分别输入5个int型整数、5个float 型实数、5个long型正整数。 
Output 
分别输出5个int型整数的最大值、5个float 型实数的最大值、5个long型正整数的最大值。 
Sample Input

11 22 666 44 55 
11.11 22.22 33.33 888.88 55.55 
1234567 222222 333333 444444 555555

Sample Output

666 
888.88 
1234567

Hint 
Source 
zlh

import java.util.*;

import java.util.Scanner;

class Max{
     int getMax(int a,int b,int c,int d,int e) {
        int m = Math.max(a, b);
        m = Math.max(m, c);
        m = Math.max(m, d);
        m = Math.max(m, e);
        return m;
    }
     float getMax(float a,float b,float c,float d,float e) {
        float m = Math.max(a, b);
        m = Math.max(m, c);
        m = Math.max(m, d);
        m = Math.max(m, e);
        return m;
    }
     long getMax(long a,long b,long c,long d,long e) {
        long m = Math.max(a, b);
        m = Math.max(m, c);
        m = Math.max(m, d);
        m = Math.max(m, e);
        return m;
    }
}
public class Main {
    public static void main(String args[]){
        Scanner input = new Scanner(System.in);
        Max mx = new Max();
        int a = mx.getMax(input.nextInt(), input.nextInt(), input.nextInt(), input.nextInt(), input.nextInt());
        float b = mx.getMax(input.nextFloat(), input.nextFloat(), input.nextFloat(), input.nextFloat(), input.nextFloat());
        long c = mx.getMax(input.nextLong(), input.nextLong(), input.nextLong(), input.nextLong(), input.nextLong());
        System.out.println(a);
        System.out.println(b);
        System.out.println(c);
        input.close();
    }
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值