ACM —— Argus

9 篇文章 0 订阅
6 篇文章 0 订阅

Argus

题目描述

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.
Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes."
Query-2: "Return the average temperature measured on each floor over the past 10 minutes."

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.

For the Argus, we use the following instruction to register a query:
Register Q_num Period

Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds.

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num. 

输入

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#".

The second part is your task. This part contains only one line, which is one positive integer K (<= 10000).

输出

You should output the Q_num of the first K queries to return the results, one number per line.

样例输入

Register 2004 200
Register 2005 300
#
5

样例输出

2004
2005
2004
2004
2005

啊又是英文题。。。看了一遍,一脸懵逼。。。果断看着输入输出理解题意了。
这道题基本就是输入n组数字以及这个数字对应的轮回时间,在k次输出的情况下,每次输出时间最小的那个,输出后时间+循环周期;当时间相同时,按照数字大小输出;
这道题可以利用C++ STL中的优先队列,但由于使用了结构体,故我们在结构体中重新定义排序规则(重载操作符);

样例代码

#include <bits/stdc++.h>

using namespace std;

struct Argus
{
    int num, period, time;
    bool operator < (const Argus &s ) const  //重载操作符,重新定义排序规则
    {
        return time > s.time || (time == s.time && num > s.num);
    }
};

int main()
{
    int k;
    char a[10];
    priority_queue<Argus> pq;
    Argus argus;
    while(cin >> a && (a[0] != '#'))
    {
        scanf("%d %d", &argus.num, &argus.period);
        argus.time = argus.period;
        pq.push(argus);
    }
    cin >> k;
    while(k--)
    {
        Argus w = pq.top();
        pq.pop();  //先退出队列;
        printf("%d\n", w.num);
        w.time += w.period;  //更新时间后重新压入队列;
        pq.push(w);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值