1013. Battle Over Cities (25)

题目链接:http://www.patest.cn/contests/pat-a-practise/1013

题目:



时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0

分析:

这是一道并查集的拓展题,题目的意思是原本城市和道路,也就是联通图,当某一个城市被占领的时候,则其相连的道路都失效。那么我们要找到需要使其剩下的城市依旧连通所需要修复的道路数目。


案例分析:

第一行:3个城市,2条道路,3个查询

第二行:1到2有一条道路

第三行:1到3有一条道路

第四行,三个查询

结果:

如果城市1被占领,则2和3都是孤立的,不连通,相当于并查集的两个集合,Tree[i] = -1,所以需要修复1条道路

如果城市2/3被占领,因为剩下的城市连接1的道路都还在,所以都还连通着,所以需要修复0条道路。


AC代码:

#include<iostream>
#include<vector>
using namespace std;
int Tree[1001];
int findRoot(int x){
 if(Tree[x] == -1)return x;
 else{
  int tmp = findRoot(Tree[x]);
  Tree[x] = tmp;
  return tmp;
 }
}
struct R{
 int s;
 int t;
};//路的结构体
vector<R> road;
int q[1001];//记录查询的城市
int main(void){
 int n,m,k;
 int i,j;
 while(scanf("%d%d%d",&n,&m,&k) != EOF){
  road.clear();
  for(i = 0; i < m; i ++){
   R tmp;
   scanf("%d%d",&tmp.s,&tmp.t);
   road.push_back(tmp);
  }
  for(i = 0; i < k; i ++){
   scanf("%d",&q[i]);
  }
  for(i = 0; i < k; i ++){
   for(j = 1; j <= n; j ++)Tree[j] = -1;//每次新查询时都初始化
   for(j = 0; j < m; j ++){//遍历所有已知的路
    int a = road[j].s;
    int b = road[j].t;
    int lost = q[i];
    if(a != lost  && b != lost){//如果都不是失守的城市,则把它们连通
     a = findRoot(a);
     b = findRoot(b);
     if(a != b)Tree[a] = b;
    }
   }
   int ans = 0;
   for(j = 1; j <= n; j ++)
    if(Tree[j] == -1) ans ++;//不连通,则需要修路
   printf("%d\n",ans - 2);//减去一个根节点的1,和点比线本身就多的1
  }
 }
 return 0;
}


——Apie陈小旭


时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值