1081. Rational Sum (20)

题目链接:http://www.patest.cn/contests/pat-a-practise/1081
题目:

Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers "a1/b1 a2/b2 ..." where all the numerators and denominators are in the range of "long int". If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form "integer numerator/denominator" where "integer" is the integer part of the sum, "numerator" < "denominator", and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:
7/24

分析:
rational number 有理数
numerator/denominato 分子/分母
也许会有最后和为0的情况
*注意不要先求分母的最小公倍数,这样会造成long long 的返回过大而溢出,应该按两个两个算
AC代码:
#include<stdio.h>
#include<iostream>
//#include<math.h>
using namespace std;
long long int gcd(long long int a, long long int b){
 if (b == 0)return a;
 else return gcd(b, a%b);
}
long long lcm(long long a, long long b){
 return a / gcd(a, b) *b;
}
int main(){
 freopen("F://Temp/input.txt", "r", stdin);
 int N;
 cin >> N;
 long long *numerator = new long long[N];
 long long *denominator = new long long[N];
 for (int i = 0; i < N; i++){
  scanf("%lld/%lld", &numerator[i], &denominator[i]);
 }
 long long res_denominator = 1, res_numerator = 0;
 //for (int i = 0; i < N; i++){
 //	res_denominator = lcm(res_denominator, denominator[i]);
 //}
 //for (int i = 0; i < N; i++){
 //	res_numerator += numerator[i] * res_denominator / denominator[i];
 //}
 for(int i= 0;i< N;i ++){
  res_numerator = res_denominator*numerator[i] + res_numerator*denominator[i];
  res_denominator *= denominator[i];
  int common = gcd(res_denominator, res_numerator);
  res_denominator /= common;
  res_numerator /= common;
 }
 if (res_numerator == 0){
  printf("0\n");
  return 0;
 }
 long long zhengshu = res_numerator / res_denominator;
 res_numerator -= zhengshu * res_denominator;
 //这一步有错误,当res_numerator为负数时,结果为负,所以会有-3/1+3/2结果为-1 1/-2的情况
 if (zhengshu != 0 && res_numerator == 0){
  printf("%lld\n", zhengshu);
 }
 else if (zhengshu == 0 && res_numerator != 0){
  printf("%lld/%lld\n", res_numerator, res_denominator);
 }
 else if (zhengshu != 0 && res_numerator != 0){
  printf("%lld %lld/%lld\n", zhengshu, res_numerator, res_denominator);
 }
 return 0;
}


截图:

——Apie陈小旭
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值