2015ACM/ICPC亚洲区上海站 LCM Walk

LCM Walk

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 682 Accepted Submission(s): 358

Problem Description
A frog has just learned some number theory, and can’t wait to show his ability to his girlfriend.

Now the frog is sitting on a grid map of infinite rows and columns. Rows are numbered 1,2,⋯ from the bottom, so are the columns. At first the frog is sitting at grid (sx,sy), and begins his journey.

To show his girlfriend his talents in math, he uses a special way of jump. If currently the frog is at the grid (x,y), first of all, he will find the minimum z that can be divided by both x and y, and jump exactly z steps to the up, or to the right. So the next possible grid will be (x+z,y), or (x,y+z).

After a finite number of steps (perhaps zero), he finally finishes at grid (ex,ey). However, he is too tired and he forgets the position of his starting grid!

It will be too stupid to check each grid one by one, so please tell the frog the number of possible starting grids that can reach (ex,ey)!

Input
First line contains an integer T, which indicates the number of test cases.

Every test case contains two integers ex and ey, which is the destination grid.

⋅ 1≤T≤1000.
⋅ 1≤ex,ey≤109.

Output
For every test case, you should output “Case #x: y”, where x indicates the case number and counts from 1 and y is the number of possible starting grids.

Sample Input

3
6 10
6 8
2 8

Sample Output

Case #1: 1
Case #2: 2
Case #3: 3

Source
2015ACM/ICPC亚洲区上海站-重现赛(感谢华东理工)

链接 http://acm.hdu.edu.cn/showproblem.php?pid=5584

题意

当前在(x,y)位置时,下一步移动只能移动到(x+z,y)或(x,y+z),z=lcm(x,y)。现在给出终点位置,问有多少个起点能到达该终点。

思路

假设当前位置为(a’,b’),由于移动过程中移动距离均为lcm,所以可以先将a’,b’分别除以gcd(a’,b’)化简计算,化简后为(a,b),a,b互质,lcm(a,b)=a*b。则有移动距离y=lcm(a,b)>=max(a,b)。
假设a<=b,则b为改变后的点,假设之前为x,则有b=x+y=x+a* x=(a+1)*x,存在x等价于b%(a+1)==0,然后将b更新为x即可,否则跳出递归。

代码

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
int gcd(int a,int b)
{
    return a==0 ? b : gcd(b%a,a);
}
int main()
{
    //freopen("F:\\c\\duipai\\data.txt","r",stdin);
    //freopen("F:\\c\\duipai\\out_wrong.txt","w",stdout);
    int T,t,a,b,ans,x,m,k;
    scanf("%d",&T);
    for (int i=1;i<=T;i++)
    {
        ans=1;
        scanf("%d %d",&a,&b);
        while (1)
        {
            if (a>b) swap(a,b);
            k=gcd(a,b);
            a/=k;
            b/=k;
            if (b%(a+1)==0)
            {
                ans++;
                b/=a+1;
            }
            else break;
        }
        printf("Case #%d: %d\n",i,ans);
    }
    return 0;
}

PS

写完了再看结论和代码感觉不难。。。但是一开始没想到把a,b化成互质的。。。不化简好像有点复杂的,一直在WA。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值