[洛谷]P2925 [USACO08DEC]干草出售Hay For Sale (#动态规划 -背包 -1.5)

题目描述

Farmer John suffered a terrible loss when giant Australian cockroaches ate the entirety of his hay inventory, leaving him with nothing to feed the cows. He hitched up his wagon with capacity C (1 <= C <= 50,000) cubic units and sauntered over to Farmer Don’s to get some hay before the cows miss a meal.

Farmer Don had a wide variety of H (1 <= H <= 5,000) hay bales for sale, each with its own volume (1 <= V_i <= C). Bales of hay, you know, are somewhat flexible and can be jammed into the oddest of spaces in a wagon.

FJ carefully evaluates the volumes so that he can figure out the largest amount of hay he can purchase for his cows.

Given the volume constraint and a list of bales to buy, what is the greatest volume of hay FJ can purchase? He can’t purchase partial bales, of course. Each input line (after the first) lists a single bale FJ can buy.

约翰遭受了重大的损失:蟑螂吃掉了他所有的干草,留下一群饥饿的牛.他乘着容量为C(1≤C≤50000)个单位的马车,去顿因家买一些干草. 顿因有H(1≤H≤5000)包干草,每一包都有它的体积Vi(l≤Vi≤C).约翰只能整包购买,

他最多可以运回多少体积的干草呢?

输入输出格式

输入格式: 
Line 1: Two space-separated integers: C and H

Lines 2..H+1: Each line describes the volume of a single bale: V_i 
输出格式: 
Line 1: A single integer which is the greatest volume of hay FJ can purchase given the list of bales for sale and constraints. 
输入输出样例

输入样例#1: 
7 3 



输出样例#1: 

说明

The wagon holds 7 volumetric units; three bales are offered for sale with volumes of 2, 6, and 5 units, respectively.

Buying the two smaller bales fills the wagon.
 


思路

01背包。

#include <stdio.h>
#include <iostream>
using namespace std;
int dp[1000001],w[6001],v[6001],n,m;
int main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);
	int i,j;
	cin>>m>>n;//背包容量m和物品数量n 
	for(i=1;i<=n;i++)
	{
		cin>>w[i];
	}
	for(i=1;i<=n;i++)
	{
		for(j=m;j>=w[i];j--)
		{
			if(dp[j-w[i]]+w[i]>dp[j])
			{
				dp[j]=dp[j-w[i]]+w[i];
			}
		}
	}
	cout<<dp[m]<<endl;
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值