题目描述
FJ
and his cows enjoy playing a mental game. They write down the numbers from 11 toN(1 \le N \le 10)N(1≤N≤10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4N=4) might go like this:
3 1 2 4
4 3 6
7 9
16
Behind FJ
's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number NN. Unfortunately, the game is a bit above FJ
's mental arithmetic capabilities.
Write a program to help FJ
play the game and keep up with the cows.
有这么一个游戏:
写出一个11至NN的排列a_iai,然后每次将相邻两个数相加,构成新的序列,再对新序列进行这样的操作,显然每次构成的序列都比上一次的序列长度少11,直到只剩下一个数字位置。下面是一个例子:
3,1,2,43,1,2,4
4,3,64,3,6
7,97,9
1616
最后得到1616这样一个数字。
现在想要倒着玩这样一个游戏,如果知道NN,知道最后得到的数字的大小sumsum,请你求出最初序列a_iai,为11至NN的一个排列。若答案有多种可能,则输出字典序最小的那一个。
[color=red]管理员注:本题描述有误,这里字典序指的是1,2,3,4,5,6,7,8,9,10,11,121,2,3,4,5,6,7,8,9,10,11,12
而不是1,10,11,12,2,3,4,5,6,7,8,91,10,11,12,2,3,4,5,6,7,8,9[/color]
输入输出格式
输入格式:
两个正整数n,sum。
输出格式:
输出包括1行,为字典序最小的那个答案。
当无解的时候,请什么也不输出。(好奇葩啊)
输入输出样例
输入样例#1
4 16
输出样例#1
3 1 2 4
说明
对于40\%40%的数据,n≤7n≤7;
对于80\%80%的数据,n≤10n≤10;
对于100\%100%的数据,n≤12,sum≤12345n≤12,sum≤12345。
思路
dfs大法好!简单粗暴没得跑!
其实就是和全排列一个概念。
#include <stdio.h>
#include <iostream>
#include <algorithm>
using namespace std;
int a[21],dp[21][21],n,lxy,f;
bool b[21];
void dfs(int i,int s)//i是第几层,s是当前答案
{
if(s>lxy || f==1)//比数字大是显然是不可以作为答案的,另外如果已经找到了一种算符就不用再找了
{
return;
}
register int j;
if(i==n+1 && s==lxy)//如果到达边界并且正好等于数字的大小
{
for(j=1;j<=n;j++)
{
cout<<a[j]<<' ';
}
f=1;//标记走过了,剩下的都不用再走了
return;
}
for(j=1;j<=n;j++)
{
if(b[j]==0)
{
a[i]=j;//其实可以用next_permutation,但是到13的时候会TLE,也许可以优化。
b[j]=1;//这个其实就是全排列思想
dfs(i+1,s+j*dp[n][i]);
b[j]=0;//为什么要回溯?因为这是要搜索到所有的算符种数
}
}
return;
}
signed main()
{
ios::sync_with_stdio(false);
cin.tie(0);
cout.tie(0);
register int i,j;
cin>>n>>lxy;
dp[1][1]=1;
for(i=2;i<=n;i++)
{
for(j=1;j<=i;j++)
{
dp[i][j]=dp[i-1][j-1]+dp[i-1][j];//先把杨辉三角算出来
}
}
dfs(1,0);
return 0;
}