[洛谷]P2853 [USACO06DEC]牛的野餐Cow Picnic (#图的遍历)

36 篇文章 0 订阅
26 篇文章 0 订阅

题目描述

The cows are having a picnic! Each of Farmer John's K (1 ≤ K ≤ 100) cows is grazing in one of N (1 ≤ N ≤ 1,000) pastures, conveniently numbered 1...N. The pastures are connected by M (1 ≤ M ≤ 10,000) one-way paths (no path connects a pasture to itself).

The cows want to gather in the same pasture for their picnic, but (because of the one-way paths) some cows may only be able to get to some pastures. Help the cows out by figuring out how many pastures are reachable by all cows, and hence are possible picnic locations.

K(1≤K≤100)只奶牛分散在N(1≤N≤1000)个牧场.现在她们要集中起来进餐.牧场之间有M(1≤M≤10000)条有向路连接,而且不存在起点和终点相同的有向路.她们进餐的地点必须是所有奶牛都可到达的地方.那么,有多少这样的牧场呢?

输入输出格式

输入格式:

Line 1: Three space-separated integers, respectively: K, N, and M

Lines 2..K+1: Line i+1 contains a single integer (1..N) which is the number of the pasture in which cow i is grazing.

Lines K+2..M+K+1: Each line contains two space-separated integers, respectively A and B (both 1..N and A != B), representing a one-way path from pasture A to pasture B.

输出格式:

Line 1: The single integer that is the number of pastures that are reachable by all cows via the one-way paths.

输入输出样例

输入样例#1

2 4 4
2
3
1 2
1 4
2 3
3 4

输出样例#1

2

说明

The cows can meet in pastures 3 or 4.


思路

真的是一道练习图的遍历的好题。 

题意:对每个奶牛所在的点跑一遍深度优先遍历,找到遍历的次数正好等于k(奶牛数)的点,输出这样的点的数量。

#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
int a[1001][1001],cow[1001],n,m,k,s[1001],vis[1001],lxy;//a是邻接矩阵,cow是奶牛的点,s为每个点被遍历的次数,vis判断点是否被访问过,lxy是答案 
void dfs(int i)//图的深度优先遍历 
{
	++s[i];//这个点的遍历次数+1 
	vis[i]=1;//标记已经访问过 
	register int j;
	for(j=1;j<=n;j++)//搜索当前点是否还有连边 
	{
		if(vis[j]==0 && a[i][j])//没被访问过 && 当前节点有连边 
		{
			dfs(j);//从j开始继续遍历 
		}
	}
}
signed main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);
	cout.tie(0);
	register int i,j;
	cin>>k>>n>>m;
	for(i=1;i<=k;i++)
	{
		cin>>cow[i];
	}
	for(i=1;i<=m;i++)
	{
		int u,v;
		cin>>u>>v;
		a[u][v]=1;//注意是有向边 
	}
	for(i=1;i<=k;i++)
	{
		memset(vis,0,sizeof(vis));
		dfs(cow[i]);//对每个枚举的点进行深度优先遍历 
	}
	for(i=1;i<=n;i++)
	{
		if(s[i]==k)
		{
			lxy++;//统计答案 
		}
	}
	cout<<lxy<<endl;
	return 0;
}

 

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值