杭电ACM1049的解题报告

7 篇文章 0 订阅
5 篇文章 0 订阅

Climbing Worm

Problem Description

An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.

 

 

Input

There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.

 

 

Output

Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.

 

 

Sample Input

10 2 1

20 3 1

0 0 0 

 

Sample Output

17

19

  

    这道题目的大概意思就是说一条蠕虫从井底往上爬,井深n英寸,蠕虫每爬一分钟上升u英寸,然后就要休息一分钟往下掉d英寸,保证上爬距离u大于下掉距离d,当然最后一次往上爬未满一分钟就到达井上面也算是一分钟,求爬到井上面需要多少分钟。有多组测试数据,当n=0的时候结束。

以每次两分钟上升(u-d)英寸来算,到最后快到井上面时肯定在往上爬的时候到达的井上面,所以把井深n减去一个上爬距离u,再计算上升(n-u)英寸需要爬多少个两分钟,最后再加一分钟结果就出来了。计算有多少个两分钟时,因为不满一分钟也算一分钟,所以(n-u)/(u-d),并且把余数收上来就是次数。

添加几组数据:

Sample Input

20 1 0

5 8 2

20 5 3

0 0 0 

Sample Output

39

1

17

附上C代码:

#include<stdio.h>

int main()

{

  int n,u,d,t,c;

  while(scanf("%d%d%d",&n,&u,&d)!=EOF){

     if(n==0)

     break;

     if(u>=n)    printf("1\n");

     else{

        if((n-u)%(u-d)!=0)

        c=(n-u)/(u-d)+1;//收余数

        else c=(n-u)/(u-d);

        t=c*2+1;

        printf("%d\n",t);

     }

  }

}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值