POJ2386 Lake Counting 图DFS

找出有多少个”水洼”(W的联通块)

Sample Input

10 12
W……..WW.
.WWW…..WWW
….WW…WW.
………WW.
………W..
..W……W..
.W.W…..WW.
W.W.W…..W.
.W.W……W.
..W…….W.

Sample Output

3

解题思路

DFS

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 110;
char pic[maxn][maxn];
int vis[maxn][maxn];
int high,width;
int cnt = 0;
void dfs(int x,int y)
{
    //第x行,第y列
    if(pic[x][y] == '.' || vis[x][y]) return;
    if(x<0 || y<0 || x>=high || y>=width) return;
    vis[x][y] = 1;
    dfs(x-1,y);dfs(x+1,y);dfs(x,y+1);dfs(x,y-1);
    dfs(x-1,y-1);dfs(x-1,y+1);dfs(x+1,y-1);dfs(x+1,y+1);
}
int main()
{
    scanf("%d%d",&high,&width);
    for(int i = 0 ; i < high ; i ++) scanf("%s",pic[i]);
    for(int i = 0 ; i < high ; i ++) {
        for(int j = 0 ; j < width ; j ++) {
            if(pic[i][j] == '.') continue;
            if(vis[i][j] == 0) {
                dfs(i,j);
                cnt ++;
            }
        }
    }
    printf("%d\n",cnt);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值