PAT 1005(字符串处理)

1005 Spell It Right (20分)


Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

 ——刷pat也是非常煎熬了,今天第一道题能运用前几天学到的知识,自己写出来也是灰常开森了(虽然这个题目超级简单,哈哈哈)

一、试题分析:

  • 输入数据为非负整数N (≤10​100​​):不可使用int存储输入的数据,在这里我是使用的string类型来存储
  • 如何获取N的每一位来sum求和:循环遍历str,使用str[i]下标提取即可(所提取的只是字符类型)
  • 如何将字符类型转化为数字:str[i] - '0'
  • 如何将最后的sum和用英文单词输出:
  1. 先将数字转化为字符串(to_string(sum) ——#include<string>);
  2. 再用数组string num[]存储英文单词即可
#include <iostream>
#include <string>
using namespace std;

int main()
{
    string str;
    string strnew;
    string num[11]={"zero","one","two","three","four","five","six","seven","eight","nine","ten"}; //数组存储英文单词
    int sum=0;
    cin>>str;
    for(int i=0;i<str.size();i++){
        sum+=(str[i]-'0'); //字符转化为数字
    }

    strnew=to_string(sum); //数据转化为字符串
    for(int i=0;i<strnew.size();i++){
        if(i==0)
            cout<<num[strnew[i]-'0'];
        else
            cout<<' '<<num[strnew[i]-'0'];
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值