Sicily 1815. 计算两点间的距离
Constraints
Time Limit: 1 secs, Memory Limit: 32 MB
Description
请用类描述顶点信息,输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
Input
输入数据第一行一个整数 n,代表测试数据组数,接下来 n 行,每行由 4 个实数组成,分别表示 x1,y1,x2,y2,数据之间用空格隔开。
Output
对于每组测试数据,输出一行,结果保留两位小数。
Sample Input
2
0 0 0 1
0 1 1 0
Sample Output
1.00
1.41
^_^包含头文件“iomanip”,输出时在浮点数前加上fixed以及setprecision即可。get?
#include <iostream>
#include <iomanip>
#include <cmath>
using namespace std;
int main()
{
int T;
cin >> T;
while (T--)
{
double x1, y1, x2, y2;
cin >> x1 >> y1
>> x2 >> y2;
cout << fixed << setprecision(2)
<< sqrt((x2 - x1) * (x2 - x1) + (y2 - y1) * (y2 - y1))
<< endl;
}
return 0;
}