Sicily 1741. Jaunt around the Zhuhai Campus

Time Limit: 1 secs, Memory Limit: 32 MB

Description

The 1st Annual Guangdong Collegiate Programming Contest (GDCPC) was held in Zhuhai Campus of Zhongshan(SunYat-Sen) University last year. And now we gather again for the 2nd GDCPC in the same wonderful place. After the contest, most of the participants will probably have a jaunt around the beautiful Campus.

中山大学珠海校区

As you have seen, the main attraction of this place is the green hills surrounding. And a problem comes up now. What is the area of cross section of the hills?
This range of hills contains peaks and valleys. So before calculating the area, we have to firstly scale and write down the coordinates of the turning points. In the following graph, 7 turning points of a hill are marked.

面积示意图

Input
The first line of the input is a positive integer T.T is the number of the test cases followed.
The first line of each test cases contains only one positive integer N(1< N<=1000) which represents the number of the turning points. Then N lines follow and the ith line contains two nonnegative integers Xi(0<=Xi<=10000),Yi(0<=Yi<=10000) which represent the coordinate of the ith turning point. It is assumed that the given turning points is in X-coordinate increasing order, i.e. Xi< Xj when i< j.

Output

The output of the program should consist of one line of output for each test case. The output of each test case only contains one real number which represents the area of the cross section of the hills. The real numbers are rounded to one decimal digit. No redundant spaces are needed.

Sample Input

2
2
1 4
3 4
2
2 7
3 9
Sample Output

8.0
8.0


(^∀^●)ノシ 题目比较长,不过大意还是比较好理解的。即输入一些在平面直角坐标系中的顶点坐标计算面积——转化为计算一个一个相邻梯形面积即可。get?

#include <iostream>
#include <iomanip>
#include <vector>

using namespace std;

typedef pair<double, double> point;

inline double getArea(point& p1, point& p2)
{
    return (p1.second + p2.second) * (p2.first - p1.first) / 2;
}

int main()
{
    int T, N;
    double S, x, y;
    vector<point> pro;
    cin >> T;
    while (T--)
    {
        S = 0;
        cin >> N;
        pro.clear();
        while (N--)
        {
            cin >> x >> y;
            pro.push_back(make_pair(x, y));
        }

        for (int i = 0; i < pro.size() - 1; i++)
            S += getArea(pro[i], pro[i + 1]);
        cout << fixed << setprecision(1) << S << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值