创建第一个android 应用程序时,SDK和ADT一定要保持版本一致。


在创建一个android application project 时,不同的安卓系统版本,SDK 和ADT 版本出现的界面可能都不一样,解决的方案时,两者的版本要保持一致,切记,是一致,不是ADT版本越高越好,SDK版本高于ADT的话,更不行。(后面有解决方案:如果SDK的版本高于ADT版本如何处理)


简单的例子,我在创建一个Hi android application project时,遇到了appcompat \ res\ values21 文件夹里面缺失文件的问题。


这个截图是我吧appcompat 和 hi 文件夹从workspace里面删除后,仍然会出现的情况,可能是自动又生成了。。求大神赐教其中的奥秘,,,



刚开始生成hi project的时候,选择的activity是blank activityu,导致了出现下面的问题:提示values21 文件夹里面缺失文件,hi 和appcompat 文件夹左下角一直有红色的错号。如下图所示:




而且hi文件夹里面的src 文件夹是没有内容的,res\layout 也没有子文件和子文件夹,,经查找,确定是ADK 和 SDT 版本不一致导致的问题。


上图是修复过来以后,就是重装了ADK 版本,和SDT 同为 23.0.2 版本的,然后下拉菜单了有了layout文件夹和其子文件夹。

然后重新创建了 emptyactivity的android application project,并且 SDK 和ADT 的版本是一致的,Why project保持的良好,但是左下角还是有叹号,,这个问题小白还是没有解决,望大神赐教。。。




没有更多推荐了,返回首页