ADT和SDK版本不一致导致的问题

步入Android开发行业已经一个月,还是一个小菜鸟,得到了许多人的帮助,希望能够记录工作中出现的问题,帮助碰到同样问题的人,更好的享受编程的乐趣

其实ADT和SDK版本不一致分成两种

一、ADT版本比SDK版本高,也就是会弹出下面这个框


我的解决办法是下载一个和当前sdk版本匹配的adt,将原来高版本的adt覆盖掉(这里要参考离线安装adt的相关知识,可以自行百度,步骤比较简单)


二、SDK版本比ADT版本高,会弹出下面这个框(这个图用的别人的)


这个弹窗有两种解决办法

1、还是下载一个和当前sdk版本匹配的adt,将原来低版本的adt覆盖掉

2、就是百度最常见的方法,找到eclipse所在的Android文件夹,进入文D:\android\adt-bundle-windows-x86_64-20131030\sdk\tools\lib,找到plugin.prop

然后将23.0.0改为22.0.0或者更低的版本号即可

# begin plugin.prop  plugin.version=23.0.0 # end plugin.prop



没有更多推荐了,返回首页