BOJ 5291 Girls and Boys //二分图水题

Girls and Boys

10000ms
32768KB
This problem will be judged on HDU. Original ID:  1068
64-bit integer IO format:  %I64d      Java class name:  Main
Font Size:   
Type: 
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •                    
  • the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

    The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

    the number of students
    the description of each student, in the following format
    student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
    or
    student_identifier:(0)

    The student_identifier is an integer number between 0 and n-1, for n subjects.
    For each given data set, the program should write to standard output a line containing the result.

    Sample Input

    7
    0: (3) 4 5 6
    1: (2) 4 6
    2: (0)
    3: (0)
    4: (2) 0 1
    5: (1) 0
    6: (2) 0 1
    3
    0: (2) 1 2
    1: (1) 0
    2: (1) 0

    Sample Output

    5
    2

    Source

    #include <stdio.h>
    #include <string.h>
    
    #define p 5000
    
    bool tu[p][p];
    bool visit[p];
    int r[p];
    
    bool dfs(int a, int n)
    {
    	int i;
    	for(i=0; i<n; i++)
    	{
    		if(tu[a][i] && !visit[i])
    		{
    			visit[i] = true;
    			if(r[i]==-1 || dfs(r[i], n))
    			{
    				r[i] = a;
    				return true;
    			}
    		}
    	}
    	return false;
    }
    
    int main()
    {
    	int n;
    	int i, a, k, v;
    	int ans;
    
    	while(scanf("%d", &n)!=-1)
    	{
    		ans = 0;
    		memset(tu, false, sizeof(tu));
    		for(i=0; i<n; i++)
    		{
    			r[i] = -1;
    		}
    
    		for(i=0; i<n; i++)
    		{
    			scanf("%d: ", &a);
    			scanf("(%d)", &k);
    
    			while(k--)
    			{
    				scanf("%d", &v);
    				tu[a][v] = true;
    			}
    		}
    
    		
    		for(i=0; i<n; i++)
    		{
    			memset(visit, false, sizeof(visit));
    			if( dfs(i, n) )
    				ans++;
    		}
    		printf("%d\n", n-ans/2);
    	}
    
    	return 0;
    }


    • 0
      点赞
    • 0
      收藏
      觉得还不错? 一键收藏
    • 0
      评论
    评论
    添加红包

    请填写红包祝福语或标题

    红包个数最小为10个

    红包金额最低5元

    当前余额3.43前往充值 >
    需支付:10.00
    成就一亿技术人!
    领取后你会自动成为博主和红包主的粉丝 规则
    hope_wisdom
    发出的红包
    实付
    使用余额支付
    点击重新获取
    扫码支付
    钱包余额 0

    抵扣说明:

    1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
    2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

    余额充值