BOJ 2314 Going Home //二分图KM模板变形

Going Home

1000ms
65536KB
This problem will be judged on PKU. Original ID:  2195
64-bit integer IO format:  %lld      Java class name:  Main
Font Size:   
Type: 
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •                    
  • On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man. 

    Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point. 

    You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

    Input

    There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

    Output

    For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

    Sample Input

    2 2
    .m
    H.
    5 5
    HH..m
    .....
    .....
    .....
    mm..H
    7 8
    ...H....
    ...H....
    ...H....
    mmmHmmmm
    ...H....
    ...H....
    ...H....
    0 0
    

    Sample Output

    2
    10
    28
    

    Source

    #include <stdio.h>
    #include <string.h>
    #include <math.h>
    
    #define p 205
    #define m 999999999
    
    struct node
    {
    	int x, y;
    }man[p], hoom[p];
    
    int tu[p][p];
    int link[p], slack[p];
    int lx[p], ly[p];
    int visitx[p], visity[p];
    char ch[p][p];
    int x, y, man1, hoom1;
    
    int MAX(int a, int b)
    {
    	if(a>b)
    		return a;
    	return b;
    }
    int MIN(int a, int b)
    {
    	if(a<b)
    		return a;
    	return b;
    }
    
    int dfs(int k)
    {
    	int i, d;
    
    	visitx[k] = 1;
    	for(i=0; i<man1; i++)
    	{
    		if(visity[i])
    			continue;
    		d = lx[k]+ly[i]-tu[k][i];
    
    		if(d==0)
    		{
    			visity[i] = 1;
    			if(link[i]==-1 || dfs(link[i]))
    			{
    				link[i] = k;
    				return 1;
    			}
    		}
    		else
    			slack[i] = MIN(slack[i], d);
    	}
    	return 0;
    }
    int KM()
    {
    	int i, j, ans;
    
    	for(i=0; i<hoom1; i++)
    		link[i] = -1;
    	memset(lx, 0, sizeof(lx));
    	memset(ly, 0, sizeof(ly));
    	for(i=0; i<man1; i++)
    	{
    		for(j=0; j<hoom1; j++)
    			lx[i] = MAX(lx[i], tu[i][j]);
    	}
    	for(i=0; i<man1; i++)
    	{
    		for(j=0; j<man1; j++)
    		{
    			slack[j] = m;
    		}
    		while(1)
    		{
    			memset(visitx, 0, sizeof(visitx));
    			memset(visity, 0, sizeof(visity));
    			if(dfs(i))
    				break;
    			else
    			{
    				int d;
    				d = m;
    				for(j=0; j<man1; j++)
    				{
    					if(!visity[j])
    						d = MIN(d, slack[j]);
    				}
    				for(j=0; j<man1; j++)
    				{
    					if(visitx[j])
    						lx[j] -= d;
    					if(visity[j])
    						ly[j] += d;
    				}
    			}
    		}
    	}
    	ans = 0;
    	for(i=0; i<man1; i++)
    		ans += tu[link[i]][i];
    	return ans;
    }
    int main()
    {
    	int i, j;
    	while(scanf("%d%d", &x, &y)!=-1 && x+y!=0)
    	{
    		for(i=0; i<x; i++)
    		{			
    			scanf("%s", ch[i]);			
    		}
    		man1 = hoom1 = 0;
    		for(i=0; i<x; i++)
    		{
    			for(j=0; j<y; j++)
    			{
    				if(ch[i][j]=='H')
    				{
    					hoom[hoom1].x = i;
    					hoom[hoom1].y = j;
    					hoom1++;
    				}
    				else if(ch[i][j]=='m')
    				{
    					man[man1].x = i;
    					man[man1].y = j;
    					man1++;
    				}
    			}
    		}
    		for(i=0; i<man1; i++)
    		{
    			for(j=0; j<hoom1; j++)
    			{
    				tu[i][j] =-(abs(man[i].x-hoom[j].x) + abs(man[i].y-hoom[j].y));
    			}
    		}
    		printf("%d\n", -KM());
    	}
    	return 0;
    }


    • 0
      点赞
    • 0
      收藏
      觉得还不错? 一键收藏
    • 0
      评论

    “相关推荐”对你有帮助么?

    • 非常没帮助
    • 没帮助
    • 一般
    • 有帮助
    • 非常有帮助
    提交
    评论
    添加红包

    请填写红包祝福语或标题

    红包个数最小为10个

    红包金额最低5元

    当前余额3.43前往充值 >
    需支付:10.00
    成就一亿技术人!
    领取后你会自动成为博主和红包主的粉丝 规则
    hope_wisdom
    发出的红包
    实付
    使用余额支付
    点击重新获取
    扫码支付
    钱包余额 0

    抵扣说明:

    1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
    2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

    余额充值