非常可乐



非常可乐
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
 
Practice
 
HDU 1495
Description
大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是
没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。
 
Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。
 
Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。
 
Sample Input
 7 4 3
4 1 3
0 0 0 
 
Sample Output
 NO


#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

typedef struct rot{
    int s, n, m;
    int num;
}rot;

int s, n, m;
bool pos[101][101][101];

bool judge(rot x)
{
    if( pos[x.s][x.n][x.m] || x.s<0||x.s>s || x.m<0||x.m>m ||x.n<0||x.n>n)    return false;
    return true;

}

int bfs()
{
    rot now, next;
    queue<rot>Q;
    now.s=s; now.n=0; now.m=0; now.num=0;
    Q.push( now );
    pos[now.s][now.n][now.m] = true;
    while( !Q.empty() ){
        now=Q.front(); Q.pop();
        if(now.s==s/2 && now.m==0)    return now.num;
        //s->m;
        if( now.s>(m-now.m) ){
            next.s=now.s-(m-now.m);    next.m=m;   next.n=now.n;  next.num=now.num+1;    if(judge(next)){ Q.push(next);   pos[next.s][next.n][next.m]=true; }
        }
        else if(now.s!=0){
            next.s=0;   next.m=now.m+now.s;   next.n=now.n;   next.num=now.num+1;     if(judge(next)){ Q.push(next);   pos[next.s][next.n][next.m]=true; }
        }
        //s->n;
        if( now.s>(n-now.n) ){
            next.s=now.s-(n-now.n);    next.n=n;   next.m=now.m;  next.num=now.num+1;    if(judge(next)){ Q.push(next);   pos[next.s][next.n][next.m]=true; }
        }
        else if(now.s!=0){
            next.s=0;   next.n=now.n+now.s;   next.m=now.m;   next.num=now.num+1;     if(judge(next)){ Q.push(next);   pos[next.s][next.n][next.m]=true; }
        }

        //n->s;
        if( now.n>(s-now.s) ){
            next.n=now.n-(s-now.s);    next.s=s;   next.m=now.m;  next.num=now.num+1;    if(judge(next)){ Q.push(next);   pos[next.s][next.n][next.m]=true; }
        }
        else if(now.n!=0){
            next.n=0;   next.s=now.s+now.n;   next.m=now.m;   next.num=now.num+1;     if(judge(next)){ Q.push(next);   pos[next.s][next.n][next.m]=true; }
        }

        //n->m;
        if( now.n>(m-now.m) ){
            next.n=now.n-(m-now.m);    next.m=m;   next.s=now.s;  next.num=now.num+1;    if(judge(next)){ Q.push(next);   pos[next.s][next.n][next.m]=true; }
        }
        else if(now.n!=0){
            next.n=0;   next.m=now.m+now.n;   next.s=now.s;   next.num=now.num+1;     if(judge(next)){ Q.push(next);   pos[next.s][next.n][next.m]=true; }
        }

        //m->s;
        if( now.m>(s-now.s) ){
            next.m=now.m-(s-now.s);    next.s=s;   next.n=now.n;  next.num=now.num+1;    if(judge(next)){ Q.push(next);   pos[next.s][next.n][next.m]=true; }
        }
        else if(now.m!=0){
            next.m=0;   next.s=now.s+now.m;   next.n=now.n;   next.num=now.num+1;     if(judge(next)){ Q.push(next);   pos[next.s][next.n][next.m]=true; }
        }

        //m->n;
        if( now.m>(n-now.n) ){
            next.m=now.m-(n-now.n);    next.n=n;   next.s=now.s;  next.num=now.num+1;    if(judge(next)){ Q.push(next);   pos[next.s][next.n][next.m]=true; }
        }
        else if(now.m!=0){
            next.m=0;   next.n=now.n+now.m;   next.s=now.s;   next.num=now.num+1;     if(judge(next)){ Q.push(next);   pos[next.s][next.n][next.m]=true; }
        }

    }
    return -1;
}

int main()
{
    int ans;
    while( scanf("%d%d%d", &s,&n,&m)!=-1 ){

        if( s==0 && n==0 && m==0 )  break;

        if(m>n) { int flag=m; m=n; n=flag; }

        memset(pos, false, sizeof(pos));
        if(s%2==0)
            ans = bfs();
        else ans=-1;
        if(ans==-1)   printf("NO\n");
        else   printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值