PTA甲级 1001 a+b format 20分全过 部分测试点解析及题目翻译

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题目大意就是 把2个数的和转换为标准和 如 1000 转换为 1,000   99999 转换为 99,999

-1000000 转换为 -1,000,000  如果长度小于4就不转换   数的范围限定了 不会超过正负10万。

commas 逗号     separated into groups 分组 

#include<iostream>
#include<sstream>
using namespace std;

int main(){
    int num1,num2,seq;
    // 判断是否为负数 
    bool flag = false; 
    cin>>num1>>num2;
    
    seq = num1 + num2;
    // 如果为负数 先变为正数 
    if(seq < 0){
        seq *= -1;	
    	flag = true;
    }
    // 数字转字符串 
    stringstream ss;
    ss<<seq;
    string str = ss.str();
    
    //  长度大于3时 倒数第一个逗号插入位置 
    int lenDet = str.length() - 3;
    // 如果长度大于3 则需要插入一个逗号 
	if(lenDet > 0){
	    str.insert(lenDet,",");	    
	    // 如果字符串长度大于 6 则还需要在第二个位置插入一个逗号 
	    if(lenDet > 3) 
	       str.insert(1,",");		      	    	      
	} 
	
	// 如果为负数 插入负号  
	if(flag)	    	      
	 	str.insert(0,"-");
	 	
	cout<<str<<endl;
			
    return 0;
}

提交截图:

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值