HCIP实验2

实验要求

1, R6为ISP只能配置IP地址,R1- R5的环回为私有网段
2, R1/4/5为全连的MGRE结构,R1/2/3为星型的拓扑结构,R1为中心站点
3,所有私有网段可以互相通讯,私有网段使用OSPF完成。

IP配置

配置缺省

[R1]ip route-static 0.0.0.0 0 16.1.1.6
[R2]ip route-static 0.0.0.0 0 26.1.1.6
[R3]ip route-static 0.0.0.0 0 36.1.1.6
[R4]ip route-static 0.0.0.0 0 46.1.1.6
[R5]ip route-static 0.0.0.0 0 56.1.1.6

配置NAT

[R1]acl 2000
[R1-acl-basic-2000]rule 1 permit source any
[R1]int s4/0/0
[R1-GigabitEthernet0/0/0]nat outbound 2000
[R2]acl 2000
[R2-acl-basic-2000]rule 1 permit source any
[R2]int s4/0/0
[R2-GigabitEthernet0/0/0]nat outbound 2000
[R3]acl 2000
[R3-acl-basic-2000]rule 1 permit source any
[R3-acl-basic-2000]q
[R3]int s4/0/0
[R3-GigabitEthernet0/0/0]nat outbound 2000

[R4]acl 2000
[R4-acl-basic-2000]rule 1 permit source any
[R4-acl-basic-2000]q
[R4]int s4/0/0
[R4-GigabitEthernet0/0/0]nat outbound 2000
[R5]acl 2000
[R5-acl-basic-2000]rule 1 permit source any
[R5-acl-basic-2000]q
[R5]int s4/0/0
[R5-GigabitEthernet0/0/0]nat outbound 2000

配置MGRE

R1

[R1]int Tunnel 0/0/0
[R1-Tunnel0/0/0]tunnel-protocol gre p2mp 
[R1-Tunnel0/0/0]ip add 10.1.1.1 24	
[R1-Tunnel0/0/0]source 16.1.1.1
[R1-Tunnel0/0/0]nhrp network-id 100
[R1-Tunnel0/0/0]nhrp entry 10.1.1.5 56.1.1.5 register 
[R1-Tunnel0/0/0]nhrp entry 10.1.1.4 46.1.1.4 register
[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/1]tunnel-protocol gre p2mp 
[R1-Tunnel0/0/1]ip address 20.1.1.1 24	
[R1-Tunnel0/0/1]source 61.1.1.1
[R1-Tunnel0/0/1]nhrp network-id 101
[R1-Tunnel0/0/1]nhrp entry 20.1.1.2 26.1.1.5 register 
[R1-Tunnel0/0/1]nhrp entry 20.1.1.3 36.1.1.4 register

 R2

[R2]int Tunnel 0/0/1	
[R2-Tunnel0/0/1]tunnel-protocol gre p2mp 
[R2-Tunnel0/0/1]ip add 20.1.1.2 24
[R2-Tunnel0/0/1]source g0/0/0
[R2-Tunnel0/0/1]nhrp entry 20.1.1.1 61.1.1.1 register 
[R2-Tunnel0/0/1]nhrp network-id 101

 R3

[R3]int Tunnel 0/0/1	
[R3-Tunnel0/0/1]tunnel-protocol gre p2mp 
[R3-Tunnel0/0/1]ip add 20.1.1.3 24
[R3-Tunnel0/0/1]source g0/0/0	
[R3-Tunnel0/0/1]nhrp entry 20.1.1.1 61.1.1.1 register 
[R3-Tunnel0/0/1]nhrp network-id 101

 R4

[R4]interface Tunnel 0/0/0
[R4-Tunnel0/0/0]tunnel-protocol gre p2mp 
[R4-Tunnel0/0/0]ip address 10.1.1.4 24	
[R4-Tunnel0/0/0]source 46.1.1.4
[R4-Tunnel0/0/0]nhrp network-id 100
[R4-Tunnel0/0/0]nhrp entry 10.1.1.1 16.1.1.1 register 
[R4-Tunnel0/0/0]nhrp entry 10.1.1.5 56.1.1.5 register 

R5

[R5]int Tunnel 0/0/0
[R5-Tunnel0/0/0]tunnel-protocol gre p2mp 
[R5-Tunnel0/0/0]ip add 10.1.1.5 24	
[R5-Tunnel0/0/0]source 56.1.1.5
[R5-Tunnel0/0/0]nhrp network-id 100
[R5-Tunnel0/0/0]nhrp entry 10.1.1.1 16.1.1.1 register 
[R5-Tunnel0/0/0]nhrp entry 10.1.1.4 46.1.1.4 register

配置OSPF

R1

[R1]ospf 1 router-id 1.1.1.1
[R1-ospf-1]area 0
[R1-ospf-1-area-0.0.0.0]network 10.1.1.0 0.0.0.255
[R1-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255
[R1-ospf-1-area-0.0.0.0]network 20.1.1.0 0.0.0.255
[R1]int Tunnel 0/0/0
[R1-Tunnel0/0/0]ospf network-type broadcast
[R1]int Tunnel 0/0/1
[R1-Tunnel0/0/1]ospf network-type broadcast 

R2

[R2]ospf 1 router-id 2.2.2.2	
[R2-ospf-1]area 0
[R2-ospf-1-area-0.0.0.0]network 20.1.1.0 0.0.0.255
[R2-ospf-1-area-0.0.0.0]network 192.168.4.0 0.0.0.255
[R2]int Tunnel 0/0/1
[R2-Tunnel0/0/1]ospf network-type broadcast 

R3

[R3]ospf 1 router-id 3.3.3.3	
[R3-ospf-1]area 0
[R3-ospf-1-area-0.0.0.0]network 20.1.1.0 0.0.0.255	
[R3-ospf-1-area-0.0.0.0]network 192.168.5.0 0.0.0.255
[R3]int Tunnel 0/0/1
[R3-Tunnel0/0/1]ospf network-type broadcast 

R4 

[R4]ospf 1 router-id 4.4.4.4
[R4-ospf-1]area 0
[R4-ospf-1-area-0.0.0.0]network 10.1.1.0 0.0.0.255
[R4-ospf-1-area-0.0.0.0]network 192.168.3.0 0.0.0.255
[R4-ospf-1-area-0.0.0.0]q
[R4]int Tunnel 0/0/0
[R4-Tunnel0/0/0]ospf network-type broadcast 

R5

[R5]ospf 1 router-id 5.5.5.5	
[R5-ospf-1]area 0
[R5-ospf-1-area-0.0.0.0]network 10.1.1.0 0.0.0.255
[R5-ospf-1-area-0.0.0.0]network 192.168.2.0 0.0.0.255
[R5-ospf-1-area-0.0.0.0]q
[R5]int Tunnel 0/0/0
[R5-Tunnel0/0/0]ospf network-type broadcast

关闭水平分割

[R1]int Tunnel 0/0/1
[R1-Tunnel0/0/1]nhrp entry multicast dynamic

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值