九度OJ-题目1035 找出直系亲属

题目描述:
如果A,B是C的父母亲,则A,B是C的parent,C是A,B的child,如果A,B是C的(外)祖父,祖母,则A,B是C的grandparent,C是A,B的grandchild,如果A,B是C的(外)曾祖父,曾祖母,则A,B是C的great-grandparent,C是A,B的great-grandchild,之后再多一辈,则在关系上加一个great-。
输入:
输入包含多组测试用例,每组用例首先包含2个整数n(0<=n<=26)和m(0< m< 50), 分别表示有n个亲属关系和m个问题, 然后接下来是n行的形式如ABC的字符串,表示A的父母亲分别是B和C,如果A的父母亲信息不全,则用-代替,例如A-C,再然后是m行形式如FA的字符串,表示询问F和A的关系。
当n和m为0时结束输入。
输出:
如果询问的2个人是直系亲属,请按题目描述输出2者的关系,如果没有直系关系,请输出-。
具体含义和输出格式参见样例.

样例输入:
3 2
ABC
CDE
EFG
FA
BE
0 0

样例输出:
great-grandparent
-

来源:
2009年浙江大学计算机及软件工程研究生机试真题

#include<stdio.h>
#include<string.h>

int find(int child[30], int f1, int f2){
    int dis= 0;
    int i= f1;
    while(child[i]!= -1){
        if(child[i]== f2){
            break;
        }
        i= child[i];
        dis++;
    }
    if(child[i]== f2){
        return dis;
    }
    else{
        return -1;
    }

}

int main(){
    int child[30];
    int n, m;
    int i;
    char t[4];
    int f1, f2;
    while(scanf("%d %d", &n, &m)!=EOF){
        if(n==0 && m==0){
            break;
        }
        memset(child, -1, sizeof(child));
        for(i= 0; i< n; i++){
            memset(t, 0, sizeof(t));
            scanf("%s", t);
            if(t[1]!= '-'){
                child[t[1]-'A']= t[0]-'A';
            }
            if(t[2]!= '-'){
                child[t[2]-'A']= t[0]-'A';
            }
        }
        for(i= 0; i< m; i++){
            memset(t, 0, sizeof(t));
            scanf("%s", t);
            f1= t[0]-'A';
            f2= t[1]-'A';
            int x= find(child, f1, f2);
            int y= find(child, f2, f1);
            int res= x>y?x:y;
            if(res!= -1){
                if(res== 0){
                    if(x> y){
                        printf("parent\n");
                    }
                    else if(y> x){
                        printf("child\n");
                    }
                }
                else if(res== 1){
                    if(x> y){
                        printf("grandparent\n");
                    }
                    else if(y> x){
                        printf("grandchild\n");
                    }
                }
                else{
                    if(x> y){
                        for(int j= 0; j< res-1; j++ ){
                            printf("great-");
                        }
                        printf("grandparent\n");
                    }
                    else if(y> x){
                        for(int j= 0; j< res-1; j++ ){
                            printf("great-");
                        }
                        printf("grandchild\n");
                    }
                }
            }
            else{
                printf("-\n");
            }
        }
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值