优先队列算法

这篇博客讨论了如何帮助Farmer John以最低成本将一块长木板锯成不同长度的木板。FJ需要对木板进行N-1次切割,每次切割的成本等于木板的长度。通过使用优先队列,可以有效地按顺序选择最小长度的木板进行切割,从而降低总成本。博客中介绍了优先队列的基本操作,并提供了超时解决方案和如何创建升序和降序优先队列的方法。
摘要由CSDN通过智能技术生成

Ayit-609(2020)第六周B

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input
Line 1: One integer N, the number of planks
Lines 2… N+1: Each line contains a single integer describing the length of a needed plank
Output
Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts
Sample Input
3
8
5
8
Sample Output
34
Hint
He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

题目意思理解过之后大概解题方法为每一次对已知数排序选出最小的进行相加操作便得出最小值

#include<stdio.h>
#include<algorithm>
using namespace std;
int s[20010];
int main()
{
    int n;
    long long sum=0;
    long long sum1=0;
    long long sum2=0;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&s[i]);
        sum+=s[i];
    }
    sum1=sum;
    for(int i=0;i<n-1;i++)
    {
        sort(s,s+n);
        sum2=s[i]+s[i+1];
        s[i]=0;
        s[i+1]=sum2;
        sum+=sum2;
    }
 printf("%lld\n",sum-sum1);
    return 0;
}```


显而易见的超时Time Limit ExceedeTd
然后选择了优先队列
普及一下优先队列的函数
q.empty() //如果队列为空,则返回true,否则返回false
q.size() //返回队列中元素的个数
q.pop() //删除队首元素,但不返回其值
q.top() //返回具有最高优先级的元素值,但不删除该元素
q.push(item) //在基于优先级的适当位置插入新元素
优先队列的时间复杂度为O(logn),n为队列中元素的个数,其存取都需要时间。
//升序队列
priority_queue <int,vector,greater > q;
//降序队列
priority_queue <int,vector,less >q;

#include<stdio.h>
#include<algorithm>
#include<queue>
using namespace std;
int s[20010];
int main()
{
    priority_queue<int,vector<int>,greater<int> >q;
    int n;
    long long sum=0;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&s[i]);
        q.push(s[i]);
    }
    while(q.size()>1)
	{
		int x=q.top();
		q.pop();
		int y=q.top();
		q.pop();
		sum+=(x+y);
		q.push(x+y);
	 }
	 printf("%lld\n",sum);
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值