7-6 Root of AVL Tree

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

 

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

 

具体代码实现为:

/*********************平衡二叉树***************************/ 
#include<stdio.h>
#include<stdlib.h>

#define ElementType int  

typedef struct AVLNode *Position;
typedef Position AVLTree; /* AVL树类型 */
struct AVLNode{
    ElementType Data; /* 结点数据 */
    AVLTree Left;     /* 指向左子树 */
    AVLTree Right;    /* 指向右子树 */
    int Height;       /* 树高 */
};

AVLTree AVL_Insertion(ElementType X,AVLTree T); 

int main()
{
	int x,N;
	AVLTree T = NULL;
	
	scanf("%d",&N);
	for(int i=0; i<N; i++){
		scanf("%d",&x);
		T = AVL_Insertion(x,T);
	}
	printf("%d\n",T->Data);
	
	return 0;
}

int GetHeight(AVLTree BT)
{
	int HL,HR,MaxH;
	
	if( BT ){
		HL = GetHeight(BT->Left);  //获得左子树的高度
		HR = GetHeight(BT->Right); //获得右子树的高度
		MaxH = HL > HR ? HL : HR;  //取左右子树中较大的高度 
		return (MaxH+1);  //返回树的高度 
	}else{
		return 0;
	} 
}

int Max( int a, int b )
{
	return (a > b ? a : b);
}

AVLTree SingleLeftRotation(AVLTree A)
{
	/*注意:A必须有一个左儿子结点B*/
	/* 将A与B做左单旋,更新A与B的高度,返回新的根结点B */
	
	AVLTree B = A->Left;
	A->Left = B->Right;
	B->Right = A;
	A->Height = Max( GetHeight(A->Left),GetHeight(A->Right) )+1;
	B->Height = Max( GetHeight(B->Left),A->Height )+1; 
	
	return B;
}

AVLTree SingleRightRotation(AVLTree A)
{
	/*注意:A必须有一个右儿子结点B*/
	/* 将A与B做右单旋,更新A与B的高度,返回新的根结点B */
	
	AVLTree B = A->Right;
	A->Right = B->Left;
	B->Left = A;
	A->Height = Max( GetHeight(A->Left),GetHeight(A->Right) )+1;
	B->Height = Max( A->Height,GetHeight(B->Right) )+1; 
	
	return B;
}

AVLTree DoubleLeftRightRotation(AVLTree A)
{
	/*注意:A必须有一个左儿子结点B,且B必须有一个右儿子结点C*/
	/* 将A、B与C做两次单旋,返回新的根结点C */
	
	A->Left = SingleRightRotation(A->Left);  //将B与C做右单旋,C被返回
	return  SingleLeftRotation(A);  //将A与C做左单旋,C被返回 
}

AVLTree DoubleRightLeftRotation(AVLTree A)
{
	/*注意:A必须有一个右儿子结点B,且B必须有一个左儿子结点C*/
	/* 将A、B与C做两次单旋,返回新的根结点C */
	
	A->Right = SingleLeftRotation(A->Right);  //将B与C做左单旋,C被返回
	return  SingleRightRotation(A);  //将A与C做右单旋,C被返回 
}

AVLTree AVL_Insertion(ElementType X,AVLTree T) 
{
	/*将X插入AVL树T中,并且返回调整后的AVL树*/
	if( !T ){/*若插入的是空树,则新建包含一个结点的树*/
		T = (AVLTree)malloc(sizeof(struct AVLNode));
		T->Data = X;
		T->Height = 0;
		T->Left = T->Right = NULL; 
	}else if(X < T->Data){/*插入T的左子树*/
		T->Left = AVL_Insertion(X,T->Left);
		if( GetHeight(T->Left)-GetHeight(T->Right) == 2){/*需要左旋*/
			if(X < T->Left->Data){
				T = SingleLeftRotation(T);  //左单旋 
			}else{
				T = DoubleLeftRightRotation(T);  //左-右双旋 
			} 
		}
	}else if(X > T->Data ){/*插入T的右子树*/  
		T->Right = AVL_Insertion(X,T->Right);
		if( GetHeight(T->Left)-GetHeight(T->Right) == -2 ){/*需要右旋*/ 
			if(X > T->Right->Data){
				T = SingleRightRotation(T);  //右单旋 
			}else{
				T = DoubleRightLeftRotation(T);  //右-左双旋 
			}
		} 
	}
	/*else X==T->Data,无须插入*/ 
	T->Height = Max( GetHeight(T->Left),GetHeight(T->Right) );  //更新树高 
	
	return T;
 } 

 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值