链表之链表的拆分

题目:
数据结构实验之链表五:单链表的拆分
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic Discuss
Problem Description
输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。
Input
第一行输入整数N;;
第二行依次输入N个整数。
Output
第一行分别输出偶数链表与奇数链表的元素个数;
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。
Sample Input
10
1 3 22 8 15 999 9 44 6 1001
Sample Output
4 6
22 8 44 6
1 3 15 999 9 1001
Hint
不得使用数组!
Source
解题代码:

#include<stdio.h>
#include<stdlib.h>
struct node
{
    int data;
    struct node*next;
};
struct node*create(int n)
{
    struct node*head,*p,*tail;
    head=(struct node*)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    int i;
    for(i=1;i<=n;i++)
    {
        p=(struct node*)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    return head;
}
struct node*create2(struct node*h)
{
    struct node*h2,*tail1,*tail2,*p;
    h2=(struct node*)malloc(sizeof(struct node));
    h2->next=NULL;
    tail2=h2;
    p=h->next;
    h->next=NULL;
    tail1=h;
    while(p!=NULL)
    {
        if(p->data%2==0)
        {
            tail2->next=p;
            tail2=p;
            p=p->next;
            tail2->next=NULL;//这一个部分比较重要,要是想P向后走,就必须先把P脱离,指向原来的链表,然后再把tail 给清空,tail必须要清空,不然提交就是错误的,当然也可以再定义一个新的指针让他跑在P的前面
        }
        else
        {
            tail1->next=p;
            tail1=p;
            p=p->next;
            tail1->next=NULL;
        }
    }
    return h2;
}
void print(struct node*h)
{
    struct node *p;
    p=h->next;
    while(p!=NULL)
    {
        if(p==h->next)
        {
            printf("%d",p->data);
        }
        else
        {
            printf(" %d",p->data);
        }
       p=p->next;
    }
    printf("\n");
}
void num(struct node*h)
{
    struct node*p;
    int c=0;
    p=h->next;
    while(p!=NULL)
    {   c++;
        p=p->next;
    }
    printf("%d",c);
}
int main()
{
    int n;
    scanf("%d",&n);
    struct node*h,*h2;
    h=create(n);
    h2=create2(h);
    num(h2);
    printf(" ");
    num(h);
    printf("\n");
    print(h2);
    print(h);
    return 0;
}

思路:链表的拆分就是新建立一个头指针,把符合条件的数都连接到这个指针后面,另外条件的就连接到另一个指针上;注意的点就是拆分的时候指针的用法,要与链表的归并相区分

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值