数据结构实验之二叉树四:(先序中序)还原二叉树

数据结构实验之二叉树四:(先序中序)还原二叉树
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic Discuss
Problem Description

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。
Input

输入数据有多组,每组数据第一行输入1个正整数N(1 <= N <= 50)为树中结点总数,随后2行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区分大小写)的字符串。

Output

输出一个整数,即该二叉树的高度。
Sample Input

9
ABDFGHIEC
FDHGIBEAC
Sample Output

5
Hint

Source

xam

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct tree
{
    char data;
    struct tree*left,*right;
}*root;
char str1[51],str2[52];
struct tree*getbuild(int len,char *str1,char *str2)
{
    if(len==0)return NULL;
    struct tree*root;
    root=(struct tree*)malloc(sizeof(struct tree));
    root->data=str1[0];
    int i;
    for(i=0;i<len;i++)
    {
        if(str2[i]==root->data)
            break;
    }
    root->left=getbuild(i,str1+1,str2);
    root->right=getbuild(len-i-1,str1+i+1,str2+i+1);
    return root;
}//利用先序和中序来实现后序二叉树的还原
int depth(struct tree*root)
{
    int x,y;
    if(root==NULL)return 0;
    else
    {
        x=depth(root->left);
        y=depth(root->right);
        return (x>y)?(x+1):(y+1);
    }//运行到最底层,从最底层开始往上加
}
int main()
{
    int n,len,dep;
    while(~scanf("%d",&n))
    {
        scanf("%s%s",str1,str2);
        len=strlen(str2);
        root=getbuild(len,str1,str2);
        dep=depth(root);
        printf("%d\n",dep);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值