2120数据结构实验之链表五:单链表的拆分

数据结构实验之链表五:单链表的拆分
Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。
Input
第一行输入整数N;;
第二行依次输入N个整数。
Output
第一行分别输出偶数链表与奇数链表的元素个数;
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。
Sample Input
10
1 3 22 8 15 999 9 44 6 1001
Sample Output
4 6
22 8 44 6
1 3 15 999 9 1001
Hint
不得使用数组!
Source

#include<stdio.h>
#include<stdlib.h>
int sum1,sum2;
struct node
{
    int data;
    struct node*next;
};
struct node*create(int n)
{
    struct node*head1,*tail,*p;
    head1=(struct node*)malloc(sizeof(struct node));
    head1->next=NULL;
    tail=head1;
    for(int i=1;i<=n;i++)
    {
        int t;
        scanf("%d",&t);
        p=(struct node*)malloc(sizeof(struct node));
        p->data=t;
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    return head1;
}
struct node*devide(struct node*head1)
{
    struct node*p,*head2,*tail1,*tail2;
    p=head1->next;
    head1->next=NULL;
    tail1=head1;
    head2=(struct node*)malloc(sizeof(struct node));
    head2->next=NULL;
    tail2=head2;
    while(p!=NULL)
    {
        if(p->data%2==0)
        {
            tail1->next=p;
            tail1=p;
            sum1++;
        }
        else
        {
            tail2->next=p;
            tail2=p;
            sum2++;
        }
        p=p->next;
    }
    tail1->next=NULL;//这边如果不断开的话,那最后一个偶数或者奇数的指针还连接着下一个数,到最后输出的时候就会连它连接的数都输出了
    tail2->next=NULL;
   return head2;
}
void print(struct node*head)
{
    struct node*q;
    q=head->next;
    while(q!=NULL)
    {
        if(q==head->next)
        {
            printf("%d",q->data);
        }
        else printf(" %d",q->data);
        q=q->next;
    }
    printf("\n");
}
int main()
{
    sum1=0,sum2=0;
    int n;
    struct node*head2,*head1;
    scanf("%d",&n);
    head1=create(n);
    head2=devide(head1);
    printf("%d %d\n",sum1,sum2);
    print(head1);
    print(head2);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值