最短路径问题
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
平面上有n个点(n<=100),每个点的坐标均在-10000~10000之间。其中的一些点之间有连线。若有连线,则表示可从一个点到达另一个点,即两点间有通路,通路的距离为两点间的直线距离。现在的任务是找出从一点到另一点之间的最短距离。
Input
第1行为整数n。
第2行到第n+1行(共n行),每行两个整数x和y,描述了一个点的坐标(以一个空格分隔)。
第n+2行为一个整数m,表示图中连线的个数。
此后的m行,每行描述一条连线,由两个整数i和j组成,表示第1个点和第j个点之间有连线。
最后一行:两个整数s和t,分别表示源点和目标点。
Output
仅1行,一个实数(保留两位小数),表示从s到t的最短路径长度。
Sample Input
5
0 0
2 0
2 2
0 2
3 1
5
1 2
1 3
1 4
2 5
3 5
1 5
Sample Output
3.41
Hint
Source
#include<stdio.h>
#include<stdlib.h>
#include<queue>
#include<string.h>
#include<math.h>
using namespace std;
const int M=20000+5;
const int N=20000+5;
const int inf=0x3f3f3f3f;
int cnt,head[M],vis[M],n;
double dis[M];
struct node
{
int x,y;
}r[M];
struct EDGE
{
int to,next;
double w;
}edge[M];
void add(int u,int v,double w)
{
edge[cnt].to=v;
edge[cnt].w=w;
edge[cnt].next=head[u];
head[u]=cnt++;
}
double f(struct node a,struct node b)
{
return sqrt(pow(a.x-b.x,2)+pow(a.y-b.y,2));
}
void SPFA(int s,int e)
{
for(int i=1;i<=n;i++)//刚开始定义了全局变量n后又在main里面定义了n,导致进不去这里;
{
vis[i]=0;
dis[i]=inf;
}
dis[s]=0;
queue<int>q;
vis[s]=1;
q.push(s);
while(!q.empty())
{
int v=q.front();
q.pop();
vis[v]=0;
for(int i=head[v];~i;i=edge[i].next)
{
int to=edge[i].to;
double w=edge[i].w;//刚开始这里定义成了int,所以输出是3.00
if(dis[to]>dis[v]+w)
{
dis[to]=dis[v]+w;
if(!vis[to])
{
vis[to]=1;
q.push(to);
}
}
}
}
printf("%.2lf\n",dis[e]);
}
int main()
{
int m,s,e;
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
head[i]=-1;
}
for(int i=1;i<=n;i++)
{
scanf("%d%d",&r[i].x,&r[i].y);
}
scanf("%d",&m);
cnt=0;
while(m--)
{
int u,v;
scanf("%d%d",&u,&v);
// printf("%.2lf\n",f(r[u],r[v]));
add(u,v,f(r[u],r[v]));
add(v,u,f(r[u],r[v]));
}
scanf("%d%d",&s,&e);
SPFA(s,e);
return 0;
}