C++运算符重载 003:惊呆!Point竟然能这样输入输出

003:惊呆!Point竟然能这样输入输出

总时间限制: 1000ms 内存限制: 65536kB
描述
程序填空

#include <iostream> 
using namespace std;
class Point { 
	private: 
		int x; 
		int y; 
	public: 
		Point() { };
// 在此处补充你的代码
}; 
int main() 
{ 
 	Point p;
 	while(cin >> p) {
 		cout << p << endl;
	 }
	return 0;
}

输入
多组数据,每组两个整数
输出
对每组数据,输出一行,就是输入的两个整数
样例输入

2 3
4 5

样例输出

2,3
4,5

输出多了逗号,故需要虫偶哥在cout<<;
cout作为已有类,需要友元该类;
cin>>也需要重载

#include <iostream> 
using namespace std;
class Point { 
	private: 
		int x; 
		int y; 
	public: 
		Point() { };
// 在此处补充你的代码
friend istream &operator >>(istream &in,Point &s){     //返回引用的cin类型;
	in>>s.x>>s.y;
	return in;
}
friend ostream &operator <<(ostream &o,const Point &s){//返回引用的cout类型
	cout<<s.x<<","<<s.y;
	return o;
}
//重载友元 
// 多输出一个‘,’ 
}; 
int main() 
{ 
 	Point p;
 	while(cin >> p) {
 		cout << p << endl;
	 }
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值