[C++][图]Saving James Bond - Easy Version

1.题目描述

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line "Yes" if James can escape, or "No" if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No

中文分析:就是一个人现在在湖中心的小岛,坐标为(0,0),想要到岸上去,湖的大小是100*100,也就是说对于这个人而言,上下左右都是50。 小岛的半径是15,告诉这个人可以跳跃的最大距离,以及可以当作过河石子的鲨鱼的坐标,查找路径,看看能不能上岸。

2.代码

#include<stdio.h>
#include<stdlib.h>
#include<stack>
#include<queue>
#include<math.h>
#define Maxsize 100
using namespace std;
int n,R;
struct Node
{
    int x;
    int y;
    int flag=0;
}s[Maxsize];
int Issafe(int v)
{
    int ans1,ans2,ans;
    ans1=abs(s[v].x-50)>abs(s[v].x+50)?abs(s[v].x+50):abs(s[v].x-50);
    ans2=abs(s[v].y-50)>abs(s[v].y+50)?abs(s[v].y+50):abs(s[v].y-50);
    ans=ans1>ans2?ans2:ans1;
    if(ans<=R)
        return 1;
    else
        return 0;
}
int FirstJump(int v)
{
    int ans;
    ans=(s[v].x)*(s[v].x)+(s[v].y)*(s[v].y);
    ans=(int)sqrt(ans);
    if(ans<=(15+R))
        return 1;
    else
        return 0;
}
int jump(int v1,int v2)
{
    int ans;
    ans=(s[v1].x-s[v2].x)*(s[v1].x-s[v2].x)+(s[v1].y-s[v2].y)*(s[v1].y-s[v2].y);
    ans=(int)sqrt(ans);
    if(ans<=R)
        return 1;
    else
        return 0;
}
int DFS(int v)
{
    int i;
    int ans=0;
    s[v].flag=1;
    if(Issafe(v)==1)  ans=1;//可以直接返回
    for(i=0;i<n;i++)
    {
        if(s[i].flag==0&&jump(v,i)==1)//可以跨越
        {
            ans=DFS(i);
            if(ans==1)
                break;
        }
    }
    return ans;
}
void  Listcomposition()
{
    int i,ans=0;
    for(i=0;i<n;i++)
    {
        if(s[i].flag==0&&FirstJump(i)==1)//可以跳过
        {
            ans=DFS(i);
        }
        if(ans==1)
            break;
    }
    if(ans==1)
        printf("Yes\n");
    else
        printf("No\n");

}
int main()
{
    int i;
    scanf("%d %d",&n,&R);
    for(i=0;i<n;i++){
        scanf("%d %d",&s[i].x,&s[i].y);
        s[i].flag=0;
    }
    Listcomposition();
    return 0;
}

3.分析

理解了题意之后,我们首先需要判断是否需要建立一个图。如果需要建立图,那么顶点是什么?边是什么?顶点是鳄鱼、人、岸,边是人可以到达的,也就是v,w两个顶点,如果可以跳跃到达另一个节点,那么则这两个顶点之间存在边。这样想来,觉得还挺麻烦的。由于我们判断是否有边,是通过距离,所以其实不用建图。把所有的节点都存在一个结构数组就可以。第一次,找一个符合条件的节点,开始DFS。在DFS过程中,与传统不同,就是需要判断是否可以上岸了,不一样把所有节点都遍历到,只要可以上岸了,就可以停下来了。

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值