Aladdin and the Flying Carpet(素数打表)

Description

 

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 10^12) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

题解:给一对数字 a,b  。a是一个长方形的面积,问有多少种整数的边的组合可以组成面积为a的长方形,要求最短的边不得小于b。

就是求区间[b, a] 内的 a 的约数对的个数。约数对就是【4,5】【5,4】这就是一对。不考虑顺序。

根据唯一分解定理,先将a唯一分解,则a的所有正约数的个数为num = (1 + a1) * (1 + a2) *...(1 + ai),这里的ai是素因子的指数。

在处理正因子的时候要注意。并且,在num除2的时候,我们会想到num为奇数的时候直接除2会不会出错?其实刚好,只有当有一个约数所形成的边是正方形的时候,num那一定是奇数,直接/2刚好减去了正方形的情况。

代码如下:

#include <iostream>
#include <queue>
#include <math.h>
#include <stdio.h>
#define PI acos(-1)
using namespace std;
#define maxn 1000047
#define LL long long
LL a[maxn], prim[maxn],k=0;
void find_prim()//素数打表
{
    k=0;
    for(LL i=2;i<=maxn;i++)
    {
        if(!a[i])
        {
            prim[k++]=i;
            for(LL j=i*i;j<=maxn;j+=i)
            {
                a[j]=1;
            }
        }
    }
}
LL cont(LL a)
{
    if(a==0)
    {
        return 0;
    }
    LL s=1,tt=0,i=0;
    while(prim[i]<a&&i<k)
    {
        tt=0;
        if(a%prim[i]==0)
        {
            while(a%prim[i]==0)
            {
                a/=prim[i];
                tt++;
            }
        }
        s*=tt+1
        i++;
    }
    if(a>1)
    {
        s*=1+1;;//如果a不能被整分,说明还有一个素数是它的约数,此时tt=1
    }
    return s;
}
int main()
{
    LL a,b,t,cc=0;
    find_prim();
    cin>>t;
    while(t--)
    {
        cin>>a>>b;
        LL cnt=0,ans=0;
        if(b<sqrt(a))//当a*a>b时,无法构成,输出0
        {
            for(LL i=1;i<b; i++)//判断[1,b]中a的约数个数
            {
                if(a%i==0)
                {
                    cnt++;
                }
            }
            ans=cont(a)/2-cnt;
        }
        cout<<"Case "<<++cc<<": "<<ans<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值