Balloon Comes!
Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very… easy problem.
Give you an operator (+,-,*, / –denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.
Is it very easy?
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!
Input
Input contains multiple test cases. The first line of the input is a single integer T (0
Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.
Sample Input
4
+ 1 2
- 1 2
* 1 2
/ 1 2
Sample Output
3
-1
2
0.50
唯一要注意的就是除法,商为整数还是小数的情况。
#include<stdio.h>
int main()
{
int n,a,b;
char s[2];
scanf("%d",&n);
while(n--){
scanf("%s %d %d",s,&a,&b);
if(s[0]=='+')printf("%d\n",a+b);
else if(s[0]=='-')printf("%d\n",a-b);
else if(s[0]=='*')printf("%d\n",a*b);
else if(s[0]=='/' && a/b*b==a)printf("%d\n",a/b);
else printf("%.2lf\n",(double)a/b);
}
return 0;
}