HDU ACM1033——Edge

41 篇文章 0 订阅
34 篇文章 0 订阅

Edge

Problem Description

For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.
After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.

Input

The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately after the last test case.

Output

For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command “300 420 moveto”. The first turn occurs at (310, 420) using the command “310 420 lineto”. Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of “x y lineto” commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge and finish each test case by the commands stroke and showpage.

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.

Sample Input

V
AVV

Sample Output

300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage

题目大意:从一固定点出发,刚开始向右移动,之后根据所给字母重新确定其移动方向——A为顺时针转90°,V为逆时针转90°。每次转动后都会移动一段距离。依次输出即可。

#include<stdio.h>
#include<string.h>
int main()
{
	int x,y,i,p;
	int a[4]={1,0,-1,0};	/*由数组a,b来控制移动方向,0~3分别对应右,下,左,上*/
	int b[4]={0,-1,0,1};
	char s[201];
	while(scanf("%s",s)!=EOF){
		x=300;y=420;p=0;	/*初始值*/ 
		printf("%d %d moveto\n",x,y);
		x+=a[p]*10;y+=b[p]*10;
		printf("%d %d lineto\n",x,y);
		for(i=0;i<strlen(s);i++){ 
			if(s[i]=='A'){	 
				p++;
				if(p==4)p=0;	/*保证循环*/ 
			}
			else if(s[i]=='V'){
				p--;
				if(p<0)p=3;
			}
			x+=a[p]*10;y+=b[p]*10;
			printf("%d %d lineto\n",x,y);
		}
		printf("stroke\nshowpage\n");
	}
	return 0;
 } 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值