【杭电-oj】-1022-Train Problem I (栈,好)

Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31514    Accepted Submission(s): 11887


Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input
  
  
3 123 321 3 123 312
 

Sample Output
  
  
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
 

看的师父的题解,讲真师父好聪明啊!!! 看了感觉思路清楚极了。

1.这道题操作只有两种,进栈和出栈,如果待入栈火车和最顶目标相同的话,那就进入、出去两个连续的步骤。

2.如果不同,那就考虑栈顶元素和最顶目标是否相同,如果相同,则栈顶元素出栈。

3.如果进行到这一步,就表示这一轮没有火车可以出栈了,则压入一节火车,进行下一轮对比。但是这里要注意思考:是否还有待入栈火车,如果没有的话,则gameover,标记并跳出循环。

上面的过程记录一下,最后分情况输出就行啦。


#include<cstdio>
#include<cstring>
#include<stack>
#include<algorithm>
using namespace std;
int main()
{
	int n;
	char a[10],b[10];
	int op[20],num,z;
	int flag;
	while(~scanf("%d",&n))
	{
		num=1;
		z=0;
		flag=1;
		getchar();
		scanf("%s %s",a,b);
		stack<char>sk;
		for(int i=0;i<n;i++)
		{
			if(a[z]==b[i])				//待入元素a[i]和目标元素b[i]相同 直接进入再出去 
			{
				op[num++]=1;			//进入记为1,出记为0 
				op[num++]=0;
				z++;
			}
			else if(!sk.empty()&&b[i]==sk.top())	//如果栈里不为空,且目标元素b[i]与栈顶元素相同则弹出栈顶元素 
			{
				sk.pop();
				op[num++]=0;					//出记为0 
			}
			else if(z<=n)				//前面两种情况都不符合且a中有没有进栈的,就进入 
			{
				sk.push(a[z++]);		
				op[num++]=1;
				i--;					//此时b不动,则i应该减一,恢复原值 
			}
			else
			{
				flag=0;					//全部不符合则不可能 
				break;
			}
		}
		if(!flag)
			printf("No.\nFINISH\n");
		else
		{
			printf("Yes.\n");
			for(int i=1;i<num;i++)			//注意操作的num从1开始记录 
			{
				if(op[i]==1)
					printf("in\n");
				else
					printf("out\n");
			}
			printf("FINISH\n");
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值