Key Set
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 1764 Accepted Submission(s): 929
Problem Description
soda has a set
S
with
n
integers
{1,2,…,n}
. A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of
S
are key set.
Input
There are multiple test cases. The first line of input contains an integer
T
(1≤T≤105)
, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤109) , the number of integers in the set.
The first line contains an integer n (1≤n≤109) , the number of integers in the set.
Output
For each test case, output the number of key sets modulo 1000000007.
Sample Input
4 1 2 3 4
Sample Output
0 1 3 7
找到规律就会发现是求2^(n-1)-1,但是数据很大所以记得要用__int64
#include<cstdio>
__int64 dis(__int64 n,__int64 m) //这里m也要用__int64,wa了六次心里苦
{
{
__int64 ans=1;
while(m)
{
if(m&1)
ans=(ans*n)%1000000007;
n=(n*n)%1000000007;
m>>=1;
}
return ans;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
__int64 n;
scanf("%I64d",&n);
__int64 z=dis(2,n-1);
printf("%I64d\n",z-1);
}
return 0;
}